Search Unity

Bug Can't install any unity any more via unity hub always says incomplete download (ESOCKETTIMEDOUT )

Discussion in 'Unity Hub' started by Dreamwalker7, Sep 22, 2021.

?

Has this happened to any others?

  1. Yes

    100.0%
  2. No

    0 vote(s)
    0.0%
  1. Dreamwalker7

    Dreamwalker7

    Joined:
    May 2, 2017
    Posts:
    1
    I have been trying to download unity via unity hub(2.4.5) for a month now, and always at anytime the error remains the same "ESOCKETTIMEDOUT".

    Q. Which version of Unity does it happen for?
    A. All/Any version of Unity throws the same error when downloading from the unity hub.

    I tried all methods, disabling firewall and antivirus(windows defender) but to no avail.

    I tried to change the "DNS_TIMEOUT" to 500000 and "HTTP_HEAD_TIMEOUT" to 100000 in HubConfig.json
    but I don't think those reflect when unity hub executes it.

    Furthermore, I tried downloading and installing Unity manually, which I succeeded in but I can't add modules since it has been installed manually and doesn't give options to add modules inside the hub,

    I even changed the line {"2019.4.15f1":{"version":"2019.4.15f1", . .}" manual": true to "manual": false in editors.json which did enable the add modules button inside unity hub but when I try to add any module it then throws a different error "Can't locate Unity.exe" or "MISSING OR INVALID DESTINATION" even after I specify the correct secondary install path.

    Even if I add android modules manually, it doesn't include the necessary SDK JDK or NDK files.

    This is truly baffling, how come unity hasn't implemented a system to resume download if there is packet loss?
    and what is up with the UI of the hub? It doesn't give any specific error explaining what's wrong and what may have caused it and the suggested solution just vaguely slaps " Something went wrong".
     
  2. UnityJuju

    UnityJuju

    Unity Technologies

    Joined:
    Jun 15, 2021
    Posts:
    138
    Hi there! Sorry to hear you're having trouble downloading the Editor.
    If possible, could you please update your Unity Hub to V3 and check if you're still having the same issue?

    To switch to V3, open/download Unity Hub then switch to Beta Channel:
    1. Click Settings (GEAR icon)
    2. Go to Advanced
    3. In the Release Channel drop-down, choose “Beta”
    4. Wait for background download. When it’s ready, you will see a message to Restart Hub to start using V3.
    To switch back to V2, repeat the steps above, but choose “Production” instead.
     
unityunity