Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Can't hide Text Mesh Pro Gizmo in Scene

Discussion in 'UGUI & TextMesh Pro' started by funselektor, Feb 11, 2019.

  1. funselektor

    funselektor

    Joined:
    Oct 11, 2013
    Posts:
    105
    Been seeing an issue where the gizmo doesn't hide itself in the scene view if it is unchecked. It's a useful asset, but it's getting in the way of what I'm trying to do in the scene.

    If I set the icon to "none' then it will disappear for a moment, but then come back again after a couple seconds.

    On Unity 2018.3.0f2 with the latest version of TextMeshPro from package manager.

    upload_2019-2-11_10-8-1.png
     
  2. Stephan_B

    Stephan_B

    Joined:
    Feb 26, 2017
    Posts:
    6,596
    This is an issue with packages where their content is read-only and as such results in such changes not being persistent.

    A bug report has already been filled about this. Hopefully it gets addressed soon.
     
    _watcher_ likes this.
  3. UH4631

    UH4631

    Joined:
    Dec 4, 2018
    Posts:
    2
    I was having the same problem you described. However, I was able to make the icon invisible by hitting the show/hide button (the button is the textmesh pro icon) in the gizmo menu as opposed to setting the icon to none. I am using Unity 2019.1.0b1 so I don't know if this will help.
     
    niloxc, mattking99, kodo91 and 5 others like this.
  4. Stephan_B

    Stephan_B

    Joined:
    Feb 26, 2017
    Posts:
    6,596
    Changing the gizmo settings as you describe will work since those are project settings. That is how I control the visibility of those icons in my projects.

    Changing the icons assigned to the specific TMP scripts will not work since those scripts are contained in the package and read-only which is the issue that I was referencing.
     
  5. funselektor

    funselektor

    Joined:
    Oct 11, 2013
    Posts:
    105
    Thanks for the help Stephan. I tried all sorts of pressing show/hide combos and still doesn't work as expected so I'll wait for the bug to be fixed.
     
  6. Egil-Sandfeld

    Egil-Sandfeld

    Joined:
    Oct 8, 2012
    Posts:
    72
    I fixed it temporarily by removing the gizmo textures in

    Packages/TextMesh Pro/Editor Resources/Gizmos
     
  7. rosco_y

    rosco_y

    Joined:
    Aug 3, 2016
    Posts:
    127
    When I drill down in the Project Tab, I see the icons, but they don't let me delete them. Can you tell me what you did?

    --thanks
     
    Kass156 likes this.
  8. petey

    petey

    Joined:
    May 20, 2009
    Posts:
    1,827
    Maybe try right clicking on them and choose reveal in finder (or explorer) then delete them there? Unity could be protecting them.
     
    Kass156 likes this.
  9. _watcher_

    _watcher_

    Joined:
    Nov 7, 2014
    Posts:
    262
    Thanks, so i simply removed "read only" flag from Packages/TextMesh Pro/"files and subfolders" and it works perfectly now.
     
    zipoz and mgear like this.
  10. Trost_

    Trost_

    Joined:
    Dec 12, 2015
    Posts:
    17
    My god, this is so f-ing counterintuitive, that after reading this thread I was still confused and then I re-read it again in 5 min to get what's going on. :mad::mad::mad:
    This guy has a right answer, but even reading his instructions, it took me a while to realize.

    Of course now, when I know that icon is clickable it makes sense: if you click the icon - you hide the icon. The checkbox is for gizmo, which is basically a white bounding box.
    For example: camera's area of view rectangle is disabled by gismo checkbox, camera icon itself is disabled by clicking the icon in this panel. :)
    Please like my post, so I can know my time explaining this was well spent and I saved you half a hour of messing with files, as advised in other posts...
     
  11. petey

    petey

    Joined:
    May 20, 2009
    Posts:
    1,827
    Hey thanks for the tip! Sadly it doesn't stick for me :( (Good to know though!)
    Aug-02-2019 17-17-49.gif

    I've gone with the method of deleting the Gizmo directory from the TextMeshPro package. This has to be done outside of Unity so right click and go show in finder and delete them there. They will come back if you ever upgrade TMPro but it doesn't take too long to do it.
     
    nrnfrhnz and BitPax like this.
  12. Trost_

    Trost_

    Joined:
    Dec 12, 2015
    Posts:
    17
    Because even with my extensive explanations you managed to do find one more way to do it wrong. :confused:
    Don't click the dropdown triangle. Click the icon directly. RIGHT THE DAMN MIDDLE OF THAT CURSED "T"

    -
    P.S. I tried to replicate your gif (changing the icon in dropdown), and if I do that, I get console error:
    "Importer for Packages/com.unity.textmeshpro/Scripts/Runtime/TextMeshProUGUI.cs has changed in memory, but the asset is read only. Importer settings stored in the meta file will be used."
    And that's why it reverts the icon setting. But that doesn't matter. Just click EXACTLY where I told and there will be no errors, while the icon will stay hidden.
     
    Last edited: Aug 5, 2019
  13. petey

    petey

    Joined:
    May 20, 2009
    Posts:
    1,827
    Haha, yeah that’s really intuitive :) thanks for the update.
     
    schmosef likes this.
  14. Egil-Sandfeld

    Egil-Sandfeld

    Joined:
    Oct 8, 2012
    Posts:
    72
    Wow yep, that also caught me out. Thanks for detailing it, Trost_
     
    Trost_ likes this.
  15. RhythmRunneR

    RhythmRunneR

    Joined:
    Mar 19, 2013
    Posts:
    1
    I was going crazy trying to figure this out until I came across Trost_'s explanation... thanks a bunch!!!
     
  16. kendallroth

    kendallroth

    Joined:
    Nov 4, 2015
    Posts:
    20
    Definitely owe you for that @Trost_; thanks a bunch!
     
  17. JasonsFreeTime

    JasonsFreeTime

    Joined:
    May 23, 2015
    Posts:
    36
    And I too learned something new! Thanks @Trost_ !!
     
  18. GunLengend

    GunLengend

    Joined:
    Sep 24, 2014
    Posts:
    54
  19. duckSPLASH

    duckSPLASH

    Joined:
    Jul 11, 2020
    Posts:
    14
    You're my new hero.
     
  20. mikewar123

    mikewar123

    Joined:
    Jul 4, 2020
    Posts:
    2

    THANK YOU
     
  21. robm123

    robm123

    Joined:
    Jun 16, 2019
    Posts:
    6
    Oh thank goodness for this thread. Those dammmmmm things have been driving me insane!
     
  22. spilat12

    spilat12

    Joined:
    Feb 10, 2015
    Posts:
    38
    DEAR GOD... Thank you, Sir, after all this years... Bro...
     
    april_4_short likes this.
  23. User340

    User340

    Joined:
    Feb 28, 2007
    Posts:
    3,001
    Thanks a bunch for the explanation!
     
  24. sharp_web_dev

    sharp_web_dev

    Joined:
    Jan 13, 2021
    Posts:
    1
    Thanks! I love you!
     
  25. Trost_

    Trost_

    Joined:
    Dec 12, 2015
    Posts:
    17
    Thanks for the feedback everybody! I'm glad that a simple GIF helped a lot of people avoid frustration and saved time :)
     
  26. djhatvr

    djhatvr

    Joined:
    Sep 22, 2019
    Posts:
    55
    Oh MAN!!!!
    That's CRAZY!

    @Trost_, Thanks for clarifying @UH4683 work-around!!!

    So the bug still persist going into 2023...interesting...(Should be able to hide it with the check box)
     
  27. Toomblercazz

    Toomblercazz

    Joined:
    Oct 8, 2016
    Posts:
    4
    Thanks @Trost_ ! Helped me a lot, had no idea that was clickable.
     
  28. whitgroves

    whitgroves

    Joined:
    Nov 7, 2021
    Posts:
    1
    Came in clutch, appreciate it.
     
  29. Attos

    Attos

    Joined:
    Jan 31, 2015
    Posts:
    1
    Thank you!!
     
  30. sersolFM

    sersolFM

    Joined:
    Jul 25, 2023
    Posts:
    1
    This is so counterintuitive! Thank you for sharing this. Summary: CLICK ON ICON, NOT THE CHECKBOX!