Search Unity

  1. All Pro and Enterprise subscribers: find helpful & inspiring creative, tech, and business know-how in the new Unity Success Hub. Sign in to stay up to date.
    Dismiss Notice
  2. Dismiss Notice

Can't hide gizmos in scene view?

Discussion in 'Editor & General Support' started by Nicris, Mar 26, 2019.

  1. Nicris

    Nicris

    Joined:
    May 12, 2014
    Posts:
    21
    For some reason, I can't seem to hide gizmos in the scene view. I toggle the Audio Source gizmo - they don't hide, also tried adding a Light and toggling that switch, no luck. I can globally toggle gizmos in the Game view. See screenshot...

    Any help appreciated!
     

    Attached Files:

    • why.jpg
      why.jpg
      File size:
      172.9 KB
      Views:
      544
  2. Marc-Saubion

    Marc-Saubion

    Joined:
    Jul 6, 2011
    Posts:
    480
    This is not the regular audio source icon you're trying to hide. Is it from an asset store addon? You should look further in the guizmo list, it should be there under the addon name.
     
    EssexDeveloper likes this.
  3. Nicris

    Nicris

    Joined:
    May 12, 2014
    Posts:
    21
    I have not used any asset store addons for this project. Just freshly installed 2018.3 from 2017.x. I did at one point during 2017.x use that asset that lets you colorize your editor UI, if that makes any difference. Attached is the rest of the list of gizmos. I know the Light box is checked in the pic, it makes no difference for me if it's checked or not, it always shows.
     

    Attached Files:

    • why2.jpg
      why2.jpg
      File size:
      200.5 KB
      Views:
      509
  4. Nicris

    Nicris

    Joined:
    May 12, 2014
    Posts:
    21
    To test this to the max, I created a brand new Unity project. Empty scene, added a light and a sprite with an audiosource. Unity still will not hide the camera, audio, or light icons, even though all 3 of them are turned off... see image.

    Oddly, the camera's bounding box *does* disappear when the camera is turned off, but the icon itself still won't.

    Don't know what to try next... this is Unity 2018.3.10f1.
     

    Attached Files:

    • how.jpg
      how.jpg
      File size:
      183.8 KB
      Views:
      460
  5. Griz

    Griz

    Joined:
    Aug 27, 2013
    Posts:
    129
    The gizmo and icon are separate things. Try clicking the small icon that's just left from the gizmo tickbox and it will work like a charm.
    Snap 2019-08-07 at 14.06.27.png
     
  6. Brad-Newman

    Brad-Newman

    Joined:
    Feb 7, 2013
    Posts:
    155
    Wow, that is...not intuitive..
     
    LoftusRT likes this.
  7. RoyBarina

    RoyBarina

    Joined:
    Jul 3, 2017
    Posts:
    36
    Any reason for the absence of the icon toggle? (2020.20f1 & 2020.21f1)
    upload_2021-1-12_11-58-58.png

    Or any of the built-in component icons??
    upload_2021-1-12_12-54-58.png
     
    Last edited: Jan 12, 2021
    sand_lantern and reinfeldx like this.
  8. reinfeldx

    reinfeldx

    Joined:
    Nov 23, 2013
    Posts:
    121
    I'm getting this now on 2020.2.6. Could a Unity person advise?
     
  9. reinfeldx

    reinfeldx

    Joined:
    Nov 23, 2013
    Posts:
    121
    Update: Confirmed I'm also getting this in 2020.2.7. This seems to be related to installing ProBuilder and/or ProGrids in my case. I created three new test projects, all of which had the correct gizmos to start. Importing ProBuilder in one project and ProGrids in another resulted in my losing those gizmos in each project. Importing Final IK did not result in losing the gizmos. I didn't have time to test other packages.

    Any ideas why this is happening or a fix?
     
    Last edited: Mar 8, 2021
    RoyBarina likes this.
  10. RoyBarina

    RoyBarina

    Joined:
    Jul 3, 2017
    Posts:
    36
    This can be frustrating.. I didn't find any workaround or a way to control this issue yet. when they reappear (which sometimes happens) I quickly try to remember which annoying icon I wanted to hide and disable it lol
     
  11. reinfeldx

    reinfeldx

    Joined:
    Nov 23, 2013
    Posts:
    121
    Do you happen to have ProBuilder or ProGrids in that project?
     
  12. RoyBarina

    RoyBarina

    Joined:
    Jul 3, 2017
    Posts:
    36
    Yes I do have both, sorry I forgot to mention.. Don't really have time to test things at the moment
     
    Last edited: Mar 12, 2021
  13. Ady_M

    Ady_M

    Joined:
    Jul 4, 2015
    Posts:
    2
    I had the same problem with the missing gizmo icons in Unity Editor v2020.2.0f1.
    All I had to do was remove a package from the Package Manager.

    Very strange behavior. This is how I tested it:
    1. I created a new project. The gizmo icons were visible.
    2. I installed Probuilder. The gizmo icons disappeared.
    3. From the Package Manager I removed the first package that I did not need which happened to be JetBrains support. The gizmo icons came back (I did not have to restart Unity).

    I have not done any further testing, though. I don't know if it matters which package you remove.
    I hope it helps you.
     
  14. OndrejP

    OndrejP

    Joined:
    Jul 19, 2017
    Posts:
    137
    RoyBarina likes this.
  15. sand_lantern

    sand_lantern

    Joined:
    Sep 15, 2017
    Posts:
    177
    Let's be real, this issue is going to exist for forever, no chance they fix it since it seems like they don't fix anything.

    I reported a similar bug issue for a previous version where every time you restarted the project, it would reset the values for those gizmo icons. Maybe hiding them so you can't turn them off is their "fix."

    I need to be less salty about this, but it feels like Unity is beating me down every day with crap like this.
     
  16. Foulcloud

    Foulcloud

    Joined:
    Mar 23, 2014
    Posts:
    14
  17. reinfeldx

    reinfeldx

    Joined:
    Nov 23, 2013
    Posts:
    121
    The bug report indicates it has been fixed in version 5.0.4. When will this version be released or how can we access it?
     
    RoyBarina likes this.
  18. reinfeldx

    reinfeldx

    Joined:
    Nov 23, 2013
    Posts:
    121
    hi1357357 likes this.
unityunity