Search Unity

  1. New Unity Live Help updates. Check them out here!

    Dismiss Notice

Can't get legacy cache server working alongside accelerator

Discussion in 'Unity Accelerator' started by antifuzz, Feb 27, 2020.

  1. antifuzz

    antifuzz

    Joined:
    Feb 22, 2013
    Posts:
    92
    We have the new accelerator working nicely on a Linux CentOS server, but we're getting errors trying to run the legacy version alongside it. We're using version v1.0.130+g5e61869

    I have attached a zip file with the config file and log outputs from the server. There is a sub included, “legacyDisabled”, which is the log outputs when I disable the "LegacyEnabled" option in the config file.

    When legacy is enabled we see errors in the logs and ports 80 and 10080 aren’t set as listening on the server. When disabled port 80 and 10080 can be seen listening and there are no errors reported in the logs.

    Would be grateful for any help.
     

    Attached Files:

  2. hiepu3d

    hiepu3d

    Unity Technologies

    Joined:
    Jul 1, 2017
    Posts:
    18
    Hi @antifuzz , thank you for reaching out about the error you ran into with Accelerator when legacy cache is enabled. Looking at the log, it seems like there may be something wrong with the node module unity-cache-server.

    To help us better investigate what the problem is, could you please uninstall that node module and the current Accelerator, and then download the latest version of Accelerator as we are two-release ahead of v1.0.130+g5e61869? The latest version should be v1.0.196+ge1f9988.

    Then, when you install the Accelerator again, please make sure to enable Legacy cache and try to reproduce the steps that you took when you ran the previous version.
     
  3. antifuzz

    antifuzz

    Joined:
    Feb 22, 2013
    Posts:
    92
    Thanks @hiepu3d We've done as you suggested and uninstalled that node module and tried again with the latest accelerator, and it's working now.
     
    hiepu3d likes this.
unityunity