Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Can't get accelerator to work in batch mode

Discussion in 'Unity Accelerator' started by mattnewport, May 19, 2020.

  1. mattnewport


    Jan 29, 2016
    I'm trying to set up a build machine with accelerator and I can't get any cacheing in batch mode. It's a Windows VM and at the moment I am running the accelerator server on the same VM as the build. If I run Unity normally (non batch mode) I see the upload and download stats change on the accelerator admin page but when running in batch mode I don't see them change and based on the import time it doesn't seem to be using the cache server at all. I've set all the relevant command line arguments to point to the correct cache server.

    Are there any known issues with using the accelerator in batch mode? How would I go about debugging the problem? I don't see any accelerator related errors or warnings (or messages of any kind) in the log when running in batch mode.
  2. SC_Marino


    Dec 5, 2019
    I am experiencing the same issue.
    Our builds run on Linux docker images 2019.3.14f1
    Logs show no connection attempts at all but its working otherwise in editor.
  3. hiepu3d


    Unity Technologies

    Jul 1, 2017
    We have had some instructions on how to use Accelerator with Editor in batch mode that you can find here: . When the editor is in batch mode, if accelerator does not show any log relating to connections, you may want to take a look at Editor's log as well. Please let us know if this still does not work after you try out the options in the link above.