Search Unity

Can't find grid and snap settings in edit tab

Discussion in 'Getting Started' started by Koiwin, May 26, 2022.

  1. Koiwin

    Koiwin

    Joined:
    May 26, 2022
    Posts:
    1
    I'm trying to change my grid and snap settings but I don't see that option on the edit tab. Is there some advanced settings button I should press?
     
  2. MarekUnity

    MarekUnity

    Unity Technologies

    Joined:
    Jan 6, 2017
    Posts:
    204
    In Unity 2021.2 Grid Snapping has been moved to scene overlays toolbars. If it's hidden, you can toggle the visibility in the Overlays menu - shortcut key is backtick ( ` ).
     
    Last edited: Feb 9, 2023
  3. Mrgiray12

    Mrgiray12

    Joined:
    Mar 31, 2022
    Posts:
    1
    I am so dumb omg ı just move that toolbar to the right down corner and forget about it my dumb ass is trying to find it for the last 30+min
     
  4. RichAllen2023

    RichAllen2023

    Joined:
    Jul 19, 2016
    Posts:
    1,026
    If tha can't see it, put thi glasses on lol.
     
  5. Mvndz

    Mvndz

    Joined:
    Feb 8, 2023
    Posts:
    1
    You and me both
     
  6. Ziplock9000

    Ziplock9000

    Joined:
    Jan 26, 2016
    Posts:
    360
    I'm having the same issue with 2023.1.0B12

    There's no option to edit the grid size, only reset



    Documentation says it should be under where it says 'reset'

     
    TractGames, dempsey0823 and Sreeking like this.
  7. Sreeking

    Sreeking

    Joined:
    Jul 20, 2022
    Posts:
    2
    yes, even i have the same problem!
     
    murphyvjamese and Ziplock9000 like this.
  8. Sreeking

    Sreeking

    Joined:
    Jul 20, 2022
    Posts:
    2
    i don't think this solution is actually working but what i did is change the scene view to 3d, it was available, i set my values and then entered 2d mode.
     
    Ziplock9000 likes this.
  9. Gene92

    Gene92

    Joined:
    Jun 28, 2018
    Posts:
    3
    You have to switch Tool handle rotation to Global and search it in the icon with the magnet

    GifTemp.gif
     
  10. Ziplock9000

    Ziplock9000

    Joined:
    Jan 26, 2016
    Posts:
    360


    It's not even clickable for me 2023.1.0B13
     
    jaycekey and MartinAubele7 like this.
  11. Gene92

    Gene92

    Joined:
    Jun 28, 2018
    Posts:
    3
    You also need to activate the Move Tool

    GifTemp.gif
     
  12. Ziplock9000

    Ziplock9000

    Joined:
    Jan 26, 2016
    Posts:
    360
    Yes that worked. Thank You.
     
    jaycekey, DarkDeivel and Gene92 like this.
  13. FreckledRanger

    FreckledRanger

    Joined:
    May 25, 2023
    Posts:
    4
    IT'S A CHRISTMAS MIRACLE (In May)! Thank you!
     
    jaycekey and MartinAubele7 like this.
  14. ninhnimense

    ninhnimense

    Joined:
    Mar 5, 2023
    Posts:
    3
    wtf how do i press backtick?
     
  15. RoyalDeMaria

    RoyalDeMaria

    Joined:
    Aug 24, 2021
    Posts:
    3
    upload_2023-8-12_1-26-11.png

    Mine was there by default. You might want to reset the layout. Have a great day!
     
  16. MajorMcDoom

    MajorMcDoom

    Joined:
    Nov 27, 2012
    Posts:
    14
    This is honestly the worst UX I've seen from Unity in all my years of using it. This messed me up for hours.

    First of all, the visual grid shouldn't necessarily be locked to transform snapping. Many people just want the visual grid to act as a visual guide - that's it.

    Now, the only way to change the visual grid size is to be on the Move tool, be in Global mode, and to open up the Snap settings? Not to mention this is completely separate from whether or not you even enable the snap feature (whether or not it's blue).

    I really hope this gets fixed in a future version, because it makes zero sense.
     
  17. murphyvjamese

    murphyvjamese

    Joined:
    Apr 19, 2023
    Posts:
    4
    Currently, (at least in my project settings), thicker, major grid lines appear every 10 units. Is it possible to make them appear every 15 units instead? If not, that seems like it would be a nice improvement to the engine.