Search Unity

  1. Unity 2019.2 is now released.
    Dismiss Notice

Can't display gizmos in Game window when using SRP

Discussion in 'Graphics Experimental Previews' started by Aka_ToolBuddy, Sep 12, 2018.

  1. Aka_ToolBuddy

    Aka_ToolBuddy

    Joined:
    Feb 25, 2014
    Posts:
    126
    Hi,
    I am using Unity 2018.2.2f1, HD Render Pipeline 3.0.0 and SRP 3.0.0.
    In my code, I draw some lines using Debug.DrawLine method. These lines are shown in the "scene" window, but not in the "game" window. When I use the built-in rendering pipeline, instead of the HD RP, the gizmos are drawn in the "game" window too.
    I looked in the forums about similar issues, but couldn't find anything useful.
    Thanks for your help.
     
  2. Tim-C

    Tim-C

    Unity Technologies

    Joined:
    Feb 6, 2010
    Posts:
    2,093
    Hi. This is fixed for 18.3 we had to add code to core unity. will be in release 3.4.0 of srp.
     
  3. Aka_ToolBuddy

    Aka_ToolBuddy

    Joined:
    Feb 25, 2014
    Posts:
    126
    Thanks for the quick answer
     
  4. EmpireStudios

    EmpireStudios

    Joined:
    Oct 23, 2018
    Posts:
    13
    This must be broken again in 2018.2.14f1, cant see debug gizmo in scene view.
     
    Lt-ven0mI likes this.
  5. GilCat

    GilCat

    Joined:
    Sep 21, 2013
    Posts:
    458
    I don't know if it's the same issue but i can't render gizmos if HDR or Anit Aliasing are enabled on the render profile.
    I'm on LWRP 5.2.3 and Unity 2019.2a
     
    BigToe likes this.
  6. blunzn

    blunzn

    Joined:
    Jan 14, 2015
    Posts:
    10
    Another request for Gizmos in GameView: using the default LWSRP ForwardRenderer, in ForwardRenderer:Setup, having createColorTexture set to true by e.g. using a ScriptableRendererFeature, disables Gizmos in GameView. Having a custom colorAttachment seems to break Gizmo Rendering. Seen on LWRP 5.10.0
     
  7. dlich

    dlich

    Joined:
    Apr 21, 2019
    Posts:
    4
    Not sure what's causing it, but can confirm gizmos not displaying in game view on unity 2019.1 and LWRP 5.7.2

    After messing with the LWRP, updating it to 5.13 and messing with it's settings again, I found out that enabling Opaque Texture in the LWRP or the main camera causes the Gizmos to not be drawn...

    After creating a new clear LWRP project the issue seem to persist but with different settings:HDR and Anti Aliasing. If I enable any of these, the Gizmos don't show up.
     
    Last edited: May 26, 2019
  8. ZimM

    ZimM

    Joined:
    Dec 24, 2012
    Posts:
    945
    Any update on this? I'm making an SRP from scratch, can't find a way to draw Gizmos in Game view.
     
  9. BigToe

    BigToe

    Joined:
    Nov 1, 2010
    Posts:
    175
    It's definitely an issue with Anti-Aliasing and SRP. (And possibly other settings) I'm using the LWRP and if I disable anti-aliasing the gizmos show up in the game view.

    I have submitted this as a bug about a month ago and did receive a confirmation that they were able to reproduce and the issue was supposedly sent developers.
     
  10. GilCat

    GilCat

    Joined:
    Sep 21, 2013
    Posts:
    458
    This issue is know for a few months now so I wonder what is keeping it from being fixed :(
     
  11. bgmulti15a

    bgmulti15a

    Joined:
    Feb 9, 2017
    Posts:
    21
    I have wasted ONE DAY because of this bug! And it's still not fixed in Unity 2019.1.7f1
     
    GilCat likes this.
  12. phil_lira

    phil_lira

    Unity Technologies

    Joined:
    Dec 17, 2014
    Posts:
    385
  13. BigToe

    BigToe

    Joined:
    Nov 1, 2010
    Posts:
    175
    phil_lira likes this.