Search Unity

Can't build project since 12-13 October (obsolete code)

Discussion in 'Unity Cloud Build' started by niceplay_games, Oct 18, 2017.

  1. niceplay_games

    niceplay_games

    Joined:
    Jun 25, 2015
    Posts:
    14
    Can't build project since 12-13 October 2017. Unity Cloud says about some obsolete code, but I don't get any errors in my Editor. I also use Asset which has some same obsolete code parts.
    1. Why it is Error, not Warning?
    2. Why can't I see those errors in my Editor (I have latest released Unity 2017.1.1f1)
    3. How do I avoid these errors and build my project?
    4. I didn't update my Unity and didn't change anything in Unity Cloud settings. It just started to appear. Why?
    Here's those errors:

    12: [Unity] Assets/Scripts/Platform.cs(16,58): error CS0619: `UnityEngine.RuntimePlatform.OSXWebPlayer' is obsolete: `WebPlayer export is no longer supported in Unity 5.4+.'
    13: [Unity] Assets/Scripts/Platform.cs(18,61): error CS0619: `UnityEngine.RuntimePlatform.WindowsWebPlayer' is obsolete: `WebPlayer export is no longer supported in Unity 5.4+.'
    14: [Unity] Assets/Scripts/Platform.cs(36,66): error CS0619: `UnityEngine.RuntimePlatform.OSXDashboardPlayer' is obsolete: `Dashboard widget on Mac OS X export is no longer supported in Unity 5.4+.'
    15: [Unity] Assets/Scripts/Platform.cs(37,66): error CS0619: `UnityEngine.RuntimePlatform.OSXWebPlayer' is obsolete: `WebPlayer export is no longer supported in Unity 5.4+.'
    16: [Unity] Assets/Scripts/Platform.cs(39,66): error CS0619: `UnityEngine.RuntimePlatform.WindowsWebPlayer' is obsolete: `WebPlayer export is no longer supported in Unity 5.4+.'
     
    chiragpandav and DiptiPatil like this.
  2. niceplay_games

    niceplay_games

    Joined:
    Jun 25, 2015
    Posts:
    14
    Found the problem: I had not the newest version of Unity. (but when I checked for updates, It said to me "Everything is up to date"). So it is the problem in new Unity 2017.2.0f3.

    Issue closed.
     
  3. DiptiPatil

    DiptiPatil

    Joined:
    Dec 26, 2017
    Posts:
    2
    means after updating unity error solved ?
     
  4. DarkNeo

    DarkNeo

    Joined:
    Apr 27, 2014
    Posts:
    53
    Also getting this problem in Unity 2018.2.10f1 But only the OSXDashboardPlayer is obsolete.

    It's the latest version of Unity getting this error on my Mac and Windows PC from an old game package from about a year ago.

    Can't seem to fix it so far and didn't really want to test multiple versions of Unity.
     
  5. abhishek1786

    abhishek1786

    Joined:
    Apr 18, 2019
    Posts:
    1
    I am facing the same, Please Help.......if possible...
    Assets/FacebookSDK/SDK/Scripts/Constants.cs(181,38): error CS0619: `UnityEngine.RuntimePlatform.WindowsWebPlayer' is obsolete: `WebPlayer export is no longer supported in Unity 5.4+.'
     
  6. victorw

    victorw

    Unity Technologies

    Joined:
    Sep 14, 2016
    Posts:
    229
    How are you experiencing that? The error is correct, WebPlayer is obsolete (and is no longer supported by almost any browser that I know of). If you are building for WebPlayer then you will have to instead build for WebGL which provides many of the same advantages. If you are not building for WebPlayer then you should try updating the Facebook SDK or your version of Unity.
     
unityunity