Search Unity

Can't apply "Pivot Unit Mode" change in the Sprite Editor

Discussion in '2D' started by tessiof, Sep 12, 2019.

  1. tessiof

    tessiof

    Joined:
    Dec 6, 2017
    Posts:
    11
    I'm porting a LOVE 2D game from the CS50 Games course to Unity 2018.4.
    I found this documentation about making the pixel art look nicer in Unity, but I can't follow it.
    In the Sprite Editor, when I set Pivot Unit Mode to Pixels from Normalized, the Apply button
    stay grayed out and I can't click it.
    This issue says this is "by design", but how can this be if it contradicts the documentation?
     
  2. ChuanXin

    ChuanXin

    Unity Technologies

    Joined:
    Apr 7, 2015
    Posts:
    311
    "Under the 'Sprite' settings, select Custom from the Pivot drop-down menu. Then select Pixels from the Pivot Unit Mode drop-down menu. This mode allows you to input pivot positions in pixels."

    I guess what this means is that you can set the "Pivot Unit Mode" from "Normalized" to "Pixel", and this will change the Unit Type of "Custom Pivot" value to pixel units instead of from 0..1 units. You will still need to update the "Custom Pivot" value for any changes to be applied as changing the Unit Type does not actually change anything (the 0..1 unit value is stored under the hood).
     
    tessiof likes this.
  3. tessiof

    tessiof

    Joined:
    Dec 6, 2017
    Posts:
    11
    So, the value is always normalized. The "pixel" option is only for letting Unity calculate a value in the range 0..1 for you based on the pixel you want to place the pivot point on.
    Thanks, I understand now!