Search Unity

Can't apply animations to my blender model.

Discussion in 'Animation' started by booq, Sep 23, 2013.

  1. booq

    booq

    Joined:
    Sep 13, 2013
    Posts:
    2
    Hi all. I will start with that I'm pretty new to Unity. I have a rigged, skinned character made in blender where i can animate it with no problems. Im exporting that model as .fbx file with no animations. Model is made in T-pose. Im importing it to unity, Animation type > Humanoid, Configured rig as it should be etc. I have created a new animation controller and linked it to my model. As far as i know my model should play any animation that i drop into that Animation Controller (i followed official Unity3D tutorial on Mecanim) but when i hit play my char is still in t-pose. I tried animations from Raw Mocap Data pack and mecanim tutorial, nothing worked for me. I bet there is a very simple solution for that but i just can't find an answer. I hope someone can help me.
     
  2. booq

    booq

    Joined:
    Sep 13, 2013
    Posts:
    2
    I have done some animating and exported model with my own animations. They work well... almost. I can't make them loop. When i drop idle animation to AnimationController it plays only once and stop character frozen at last frame. Can't work it out. Same situation with walking animation. I pres "W" and as long as i hold it animation plays only once. Still hoping someone can help.
     
  3. Gnaws

    Gnaws

    Joined:
    Jul 1, 2008
    Posts:
    43
    When you select your FBX/character in the Project window, then select the Animations button, you should be able to select the animations assigned to the object. This is where you set the wrap mode to: play once, loop, ping pong, etc.

    You probably figured this out by now. =]
     
unityunity