Search Unity

Cannot submit change to server

Discussion in 'Unity Collaborate' started by imjusthere, May 30, 2021.

  1. imjusthere

    imjusthere

    Joined:
    Oct 12, 2012
    Posts:
    63
    I can't update my project because I keep getting this error. I've tried unlinking my project and re-uploading the entire thing and I keep getting this. The editor log is below and it doesn't seem to tell me which asset is the issue. How do I resolve this? I really need this project backed up.

    [Collab 2021-0530 16:09:24 GMT][Error] 'Cannot submit change to server' (23) returned in 'C:\buildslave\unity\build\Editor/Src/Collab/Requests/UploadRequests.cpp' at line 150
    [Collab 2021-0530 16:09:24 GMT] UploadEntryRequest failed, Reason: 400 Url: https://storage.googleapis.com/unitycloud-collab-store-production-us/dc888b10-1da0-40a1-b950-9fb8d53f4278/a25823f08edcb3c473dea2e145069fd1?GoogleAccessId=collab-app@unity-cs-collab-prd.iam.gserviceaccount.com&Expires=1622477016&Signature=H3ZcD1jb1XMRv3RytCtV7kQ6VumY4DmDh9uhFVECbu2xN0sddysE+jeK7oapcJ0pvHG34nZUFvSMSswsGNLha++YLNZil3dzUet24+6mICkHJLVa/ozW/UA20rfhBEbhBzXgc0p7+lVM1yY5WyJgioRIezkB4ya6IOuUhC9D0C353vd+vvWynuqTC3oafZdTIzy0PJTMl8ecSp+voqkzr7OTPkCtpDAWWui7dtacSwucFHATzGAB4ZCiCGSVPG957v9lEaTQqy6aNvz2nj6GCnNdSB2yJJ+oND3/M8JQg7Tdka8sc237rthGMFIAAxtv8nTWNGKvLUHoQd16y9BVUg== Result: <html><title>Error 400 (Bad Request)!!1</title></html>
    [Collab 2021-0530 16:09:38 GMT][Error] 'Cannot submit change to server' (23) returned in 'C:\buildslave\unity\build\Editor/Src/Collab/Jobs/CollabPublishAsyncJob.cpp' at line 391

    EDIT - I did more testing and submitted folders individually until I narrowed down the problem file. It's my main game scene that won't backup. I tried saving it as a different scene and uploading that and I got the same error. There is something wrong with this scene that won't allow it to be uploaded to collaborate. There are no errors in the scene and everything builds like it should. What else can I do?

    EDIT #2 - I discovered it has to do with the size of my scene. I've been using an asset from the asset store to combine meshes and reduce draw calls but it caused the scene to balloon to 3.5GB in size. No wonder it won't upload.
     
    Last edited: Jun 1, 2021
unityunity