Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We have updated the language to the Editor Terms based on feedback from our employees and community. Learn more.
    Dismiss Notice

Bug Cannot open Unity Editor by any means after Unity Hub 3.4.1 update

Discussion in 'Unity Hub' started by zbnc, Dec 15, 2022.

  1. zbnc


    Aug 5, 2022
    I took the recent update to 3.4.1 and now cannot open any projects. I can't create new projects.

    Intel i7-6800

    • Clicking on a project that was working before upgrade: spinning 'loading' icon appears, but nothing happens. After a period of time, spinning stops but no project has been opened.
    • Attempt to create new project: same behavior, spinner appears, nothing happens. Closing hub then reopening it, the project title is in list but clicking on it throws error because no project exists at that location;
    • This happens with all projects. no projects can be opened.
    The above symptoms occur on both editor versions 2019.4, 2021.3

    I have tried:
    • Reinstalling Unity Hub
    • Reinstalling Unity Editor
    • Simply restarting machine
    • recreating firewall rules
    • disabling firewall
    • restarting network adapter
    • logging out unity account
    • switching to different unity account
    • removing license

    Nothing appears in logs when this happens.
    If I delete the log file, then click on unity hub UI to open project, no logs are generated. Simply nothing happens.

    I also cannot open my project directly by either:
    attempting do directly open Unity.exe for the desired editor version OR
    opening my project and opening a scene file using 'open with -> unity'
    Luxifer69 likes this.
  2. Gennady


    Unity Technologies

    Mar 30, 2015
    Hi, thanks for reporting this.

    This is expected behavior, log file is created on a startup.

    At a first glance it sounds like a licensing issue, it would be nice to have some more information.

    Could you please:
    1. Close the Hub
    2. Edit your info-log.json file and remove its contents (or just delete the file)
    3. Start the Hub and Open/Create the project
    4. Share your Hub, licensing client and Editor logs (better through Direct Message):
    - info-log.json: %APPDATA%\UnityHub\logs\info-log.json
    - Unity.Licensing.Client.log: %LOCALAPPDATA%\Unity\Unity.Licensing.Client.log
    - Editor.log: %LOCALAPPDATA%\Unity\Editor\Editor.log

    Thank you!
    Luxifer69 likes this.
  3. atepp


    Sep 8, 2017
    hey zbnc,

    This issue was my first time in 8yrs of Unity that an error truly stopped me, took me a bit to find an answer so thought I'd share it. My setups was same OS and very similar setup to yours, I also tried all the same stuff except for messing with licences, all with no change.

    Found that the solution was basically clearing out all the cache. I went through my C:->%User%->Appdata->local/localLow/Roaming and in each one I deleted everything to do with Unity. Basically all temp files and data folders gone and everything to do with UnityHub uninstalled. Only had the standalone unity versions left installed in a different directory where I keep them. Then did a fresh install of the most recent UnityHub version and everything worked, no critical error and it got passed the black screen.

    For mods, here's my source:
    The helpful comment from Nemlar about old logs/cache or pointers, idk the exact cause of the issue myself honestly, but pointing to project or file names with brackets is what they're saying is the issue for this. Their comment mentions modifying system registry but I did not have to do that, just uninstalled and deleted all UnityHub related files under User->Appdata and re-installed, then it loaded, logged into my account and everything worked.
    Last edited: Dec 18, 2022
    Luxifer69 and Nexer8 like this.
  4. zbnc


    Aug 5, 2022
    @atepp Thank you for the idea, I hadn't thought to try that.

    Initially this did not work, but after removing my license and reactivating my license this was resolved.
    To be clear, I had previously removed and reactivated my license, but apparently the cache ALSO needed to be cleared. Neither of these steps worked individually, they both needed to be completed.

    This has been resolved, thank you
    Last edited: Dec 21, 2022
    Luxifer69 likes this.
  5. BagoDev


    Jan 2, 2017
    Also running into this issue. Seems to happen after the 3.4.0 -> 3.4.1 automatic update each time, multiple machines now.

    I've tried to delete cache appdata files, reinstall the hub, refresh the license (times out), nothing works. Oddly enough I can open newly made projects but not old ones.

    @Gennady sending you some log extracts, looks like licensing issues.

    *edit* was able to get it working with the process -> Uninstall Hub -> delete all appdata files local/locallow/roaming -> restart -> reinstall hub
    Last edited: Jan 13, 2023
  6. Gonergames


    Jun 1, 2017
    I had this same problem. Fixed it with going to Firefox Settings -> Applications -> unityhub -> change from always ask to the actual unity hub.exe file location. Clearly I use Firefox as my default browser so it may be a similar issue with your default browsers.

  7. aarushsinha20


    Mar 21, 2023
    I just downloaded unity a few days ago to make games. I had downloaded version 3.4.1. Now after using unity and closing it after i made some progress for some days, it was working properly but when I opened the unity hub today it was bootlooping which means it was stuck on the loading screen . Please provide me with a fix for my problem ASAP. I will be highly grateful to you for this.

    Thank You,
    Aarush Sinha