Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We’re making changes to the Unity Runtime Fee pricing policy that we announced on September 12th. Access our latest thread for more information!
    Dismiss Notice
  3. Dismiss Notice

Bug Cannot open project via both Unity and Unity Hub

Discussion in 'Unity Hub' started by por-chin, Mar 1, 2023.

  1. por-chin


    Jan 3, 2014
    After I upgraded Unity to version 2022.2.8f1 (from 2021.3.9f1), I could not open any project or create an entirely new one. Some of my teammates also had Unity Hub v3.4.1 crash or cannot open project. I tried to find causes and solutions and I bumped into some posts and even issued trackers that might be related to my issue.

    Bug - Cannot open Unity Editor by any means after Unity Hub 3.4.1 update - Unity Forum

    Unity Issue Tracker - Hub crashes with "Timeout! Cannot connect to Licensing Client within 60000ms" when opening it (

    Official - Stuck on Windows? Check here first! ("Unity is already in list" etc) - Unity Forum

    I tried all of these solutions but failed to solve the issue. The problem seemed to be the licensing client not working properly but not the same issue with those in the posts.

    So I dug down further by investigating log files (attached) and there is something I believe might be the root cause of the problem. When I used Hub 3.3.0 or Unity 2021.3.9f1, they used 'LocalIPC' version 1.10 or below but when I used Hub 3.4.1 or Unity 2022.2.8f1, they both used LocalIPC newer version than 1.10 which is, in the log said, 'Unsupported protocol'.

    I wonder what is this IPC protocol? How can I update it? If it is related to my issue at all? Is there any way to solve this issue?

    Attached Files: