Search Unity

Cannot find SpriteShape in unity package manager

Discussion in 'Package Manager' started by leftoversalad, Feb 12, 2019.

  1. leftoversalad

    leftoversalad

    Joined:
    Jul 9, 2015
    Posts:
    3
    I'm trying to install SpriteShape and it is not listed in the package manager:


    I checked out `manifest.json` under Packages and it looks like this:
    Code (JavaScript):
    1. {
    2.   "dependencies": {
    3.     "com.unity.ads": "2.3.1",
    4.     "com.unity.analytics": "3.2.2",
    5.     "com.unity.collab-proxy": "1.2.15",
    6.     "com.unity.package-manager-ui": "2.0.3",
    7.     "com.unity.purchasing": "2.0.3",
    8.     "com.unity.textmeshpro": "1.3.0",
    9.     "com.unity.modules.ai": "1.0.0",
    10.     "com.unity.modules.animation": "1.0.0",
    11.     "com.unity.modules.assetbundle": "1.0.0",
    12.     "com.unity.modules.audio": "1.0.0",
    13.     "com.unity.modules.cloth": "1.0.0",
    14.     "com.unity.modules.director": "1.0.0",
    15.     "com.unity.modules.imageconversion": "1.0.0",
    16.     "com.unity.modules.imgui": "1.0.0",
    17.     "com.unity.modules.jsonserialize": "1.0.0",
    18.     "com.unity.modules.particlesystem": "1.0.0",
    19.     "com.unity.modules.physics": "1.0.0",
    20.     "com.unity.modules.physics2d": "1.0.0",
    21.     "com.unity.modules.screencapture": "1.0.0",
    22.     "com.unity.modules.terrain": "1.0.0",
    23.     "com.unity.modules.terrainphysics": "1.0.0",
    24.     "com.unity.modules.tilemap": "1.0.0",
    25.     "com.unity.modules.ui": "1.0.0",
    26.     "com.unity.modules.uielements": "1.0.0",
    27.     "com.unity.modules.umbra": "1.0.0",
    28.     "com.unity.modules.unityanalytics": "1.0.0",
    29.     "com.unity.modules.unitywebrequest": "1.0.0",
    30.     "com.unity.modules.unitywebrequestassetbundle": "1.0.0",
    31.     "com.unity.modules.unitywebrequestaudio": "1.0.0",
    32.     "com.unity.modules.unitywebrequesttexture": "1.0.0",
    33.     "com.unity.modules.unitywebrequestwww": "1.0.0",
    34.     "com.unity.modules.vehicles": "1.0.0",
    35.     "com.unity.modules.video": "1.0.0",
    36.     "com.unity.modules.vr": "1.0.0",
    37.     "com.unity.modules.wind": "1.0.0",
    38.     "com.unity.modules.xr": "1.0.0"
    39.   }
    40. }
    41.  
    Looking at a getting started with 2D Sprite Shape tutorial, I saw that the path was `"com.unity.2d.spriteshape": "1.0.12" `, so I added that to my manifest.json, but it seems like that is no longer quite the right path to the module.

    I am using Unity 2018.3.0f2 Personal on Windows. Any idea why it's not showing up?
     
  2. dquek

    dquek

    Unity Technologies

    Joined:
    Apr 17, 2018
    Posts:
    36
  3. leftoversalad

    leftoversalad

    Joined:
    Jul 9, 2015
    Posts:
    3
    Ah thank you!
     
  4. niolu7

    niolu7

    Joined:
    Jun 29, 2019
    Posts:
    1
    thanks so much i too was having that same problem;)