Search Unity

Cannot exit full screen mode

Discussion in 'macOS' started by Oscar-Tsang, Feb 8, 2018.

  1. Oscar-Tsang

    Oscar-Tsang

    Joined:
    Nov 7, 2012
    Posts:
    84
    When building standalone osx game. If click the attached screen's button to enter full screen mode. The unity player will no longer able to exit full screen mode.

    If press cmd+F, to enter or exit full screen mode, is no problem. But if click the green button. It will go crazy.
    Cannot back the window mode anymore.

    It is a bug!
     

    Attached Files:

  2. JoeStrout

    JoeStrout

    Joined:
    Jan 14, 2011
    Posts:
    9,859
    What exactly does "go crazy" mean here? When you mouse up to the top of the screen, causing the menu and title bar to appear, and click the zoom (green) button again, what happens?
     
  3. Oscar-Tsang

    Oscar-Tsang

    Joined:
    Nov 7, 2012
    Posts:
    84
    No, after click the (green) button, the title bar will disappear. But, it simply no longer display again. That why it unable to go back.
    When using cmd+f or Screen.Fullscreen by code, it will not cause the title bar disappear.
    But if by click the green button, it like destroy the title bar.
    I think it should be BUG.
     
  4. JoeStrout

    JoeStrout

    Joined:
    Jan 14, 2011
    Posts:
    9,859
    No, the title bar (and menu bar) disappearing is what's the green button does on recent versions of MacOS. Try it with any app — web browser, text editor, whatever. They all do it.

    Menu bar and title bar reappear when you push the mouse up to the top of the screen, and then clicking the zoom button again exits full-screen mode.

    (Not that I like this behavior; I now always option-click the zoom button to get the old, non-full-screen zoom behavior instead. But maybe that's just me.)
     
  5. Oscar-Tsang

    Oscar-Tsang

    Joined:
    Nov 7, 2012
    Posts:
    84
    I know what normal app behavior. The title bar should not be destroy. But Unity generated app has bug, it work not like normal app.

    Basically I don't care this bug, but Apple reviewer reject my app because of this bug!
    I need to set "Resizable Window" to False to disable the "Green" Button. And than Apple approve my app.
     
  6. Oscar-Tsang

    Oscar-Tsang

    Joined:
    Nov 7, 2012
    Posts:
    84
    No one find this problem?
     
  7. greg424242

    greg424242

    Joined:
    Sep 27, 2017
    Posts:
    7
    same problem
     
  8. User340

    User340

    Joined:
    Feb 28, 2007
    Posts:
    3,001
    Same problem, plus it gets this goofy letter boxing sometimes. That's why I stuck with 5.6 for so long.

    I have submitted a bug report today, I encourage everyone else who is experiencing this issue to do the same to let them know of it's importance.
     
    Last edited: May 8, 2018
    greg424242 likes this.
  9. greg424242

    greg424242

    Joined:
    Sep 27, 2017
    Posts:
    7
    Hello,
    What is the url of bug report ?
    Thank you.
     
  10. greg424242

    greg424242

    Joined:
    Sep 27, 2017
    Posts:
    7
    Hello, the bug appear when the build is set to "allow resizable" and the user click to the green Mac toggle "go to fullscreen".

    Any idea if it will be fixed ? (in 2017.2)
     
  11. Gordan_G

    Gordan_G

    Joined:
    Oct 31, 2012
    Posts:
    12
    Facing same issue even in the application build in Unity 2018.2.8. Any work around for this?
     
  12. HdG_S

    HdG_S

    Joined:
    Jan 20, 2016
    Posts:
    5
  13. andyz

    andyz

    Joined:
    Jan 5, 2010
    Posts:
    2,269
    Yeah this, because Unity builds stilllll remember past app status even when fullscreen allowable changes.... :/
     
  14. sgr2019

    sgr2019

    Joined:
    Feb 9, 2020
    Posts:
    1
    I found a work-around: Alt+CMD+Escape exits the locked full screen.
     
    johnackley and NV_007_ like this.
  15. Cobaltgames19

    Cobaltgames19

    Joined:
    Mar 14, 2020
    Posts:
    3
    I had the same problem what I did to fix it when you are in build settings go to project settings then player then resolution and presentation and change the full-screen mode options. Screen Shot 2020-04-11 at 7.29.48 PM.png Screen Shot 2020-04-11 at 7.30.16 PM.png Screen Shot 2020-04-11 at 7.30.27 PM.png Screen Shot 2020-04-11 at 7.30.16 PM.png Screen Shot 2020-04-11 at 7.30.27 PM.png Screen Shot 2020-04-11 at 7.30.47 PM.png
     

    Attached Files:

  16. Sothling22221111

    Sothling22221111

    Joined:
    Jul 4, 2023
    Posts:
    1
    what I did I tried making the scene a bit bigger but something happened now the bottom bar is maximized and I cant see the scene, plz help.