Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Cannot assign TrailMaterial in Rederer Module of ParticleSystem

Discussion in 'General Graphics' started by Lynxed, Oct 9, 2020.

  1. Lynxed

    Lynxed

    Joined:
    Dec 9, 2012
    Posts:
    121
    Hello all!
    The version is 2020.1.6f1. Build-in RP.
    There is no field for assigning trail material.

    @richardkettlewell , please help!

    upload_2020-10-9_11-29-10.png
     

    Attached Files:

    nakai_design008 likes this.
  2. richardkettlewell

    richardkettlewell

    Unity Technologies

    Joined:
    Sep 9, 2015
    Posts:
    2,273
    Hey this seems like a bug :(

    I've just had a look at it and it seems like, if you Press "Restart" in the Scene View particle playback GUI, it will make the setting appear.
    We will get a proper fix out ASAP.

    Please let me know if this workaround works for you.
     
    Snowirbis, Crawdad, jplayne8 and 3 others like this.
  3. Lynxed

    Lynxed

    Joined:
    Dec 9, 2012
    Posts:
    121
  4. richardkettlewell

    richardkettlewell

    Unity Technologies

    Joined:
    Sep 9, 2015
    Posts:
    2,273
    nakai_design008 likes this.
  5. MadboyJames

    MadboyJames

    Joined:
    Oct 28, 2017
    Posts:
    262
    Hi, just to add to this, it seems that I cannot see the trail material field if I am viewing the particle system from a prefab in the project tab. If I open the prefab, the field appears. Not sure if this is a different issue.
     
    AlpRic likes this.
  6. richardkettlewell

    richardkettlewell

    Unity Technologies

    Joined:
    Sep 9, 2015
    Posts:
    2,273
    Please report a bug for this
     
  7. MadboyJames

    MadboyJames

    Joined:
    Oct 28, 2017
    Posts:
    262
    Bug reported.
    CASE IN-5208
     
    richardkettlewell likes this.
  8. andrespineiroc

    andrespineiroc

    Joined:
    Dec 23, 2020
    Posts:
    1
    This is not fixed yet. But the work-around did work for me.