Search Unity

  1. Read here for Unity's latest plans on OpenXR.
    Dismiss Notice

Resolved Can not get MARS working with right packages

Discussion in 'Unity MARS' started by kartoonist435, Feb 23, 2021.

  1. kartoonist435

    kartoonist435

    Joined:
    Feb 14, 2015
    Posts:
    66
    I can not get MARS working at all. I mean seriously what packages work together?
    https://docs.unity3d.com/Packages/com.unity.mars@1.2/manual/GettingStarted.html

    This link above is what I'm using to try and use MARS. I'm using the recommended Unity version 2019.4.8f1 LTS. When I import Unity MARS as per the instructions I'm immediately hit with this error.
    Library\PackageCache\com.unity.xr.management@4.0.1\Editor\XRGeneralBuildProcessor.cs(36,52): error CS0117: 'BuildPipeline' does not contain a definition for 'GetBuildTargetName'

    From here matching the other plugins to 4.0.1 doesn't work. Downgrading doesnt' work and upgrading to the newest versions doesn't work. If I follow a forum post suggesting to downgrade XRmanagement to 3.2.16 it's then automatically set higher when I reinstall the ARCore package even as far back as version 2. I'm so frustrated with this I'm about to just use ARfoundation. It's free for one and it works way way easier.
     
  2. jmunozarUTech

    jmunozarUTech

    Unity Technologies

    Joined:
    Jun 1, 2020
    Posts:
    266
  3. mtschoen

    mtschoen

    Unity Technologies

    Joined:
    Aug 16, 2016
    Posts:
    146
    Hi there! Sorry that you ran into this. Unfortunately, this is a compatibility issue with the latest available version of AR Foundation in 2019.4.8f1. In order for the MARS installer to have a one-size-fit-all package setup, we install the latest versions of everything, and it looks like you've hit a situation where this results in errors.

    To resolve this issue, please upgrade to Unity 2019.4.15f1 or newer.

    We will try to resolve this issue with AR Foundation for future users in case they run into the same problem.

    Thanks for trying MARS. Hope this helps!

    Edit: My previous message suggested downgrading AR Foundation 4.1.1, but this was incorrect. There are bugfixes in 4.1.5.
     
    Last edited: Feb 23, 2021
  4. kartoonist435

    kartoonist435

    Joined:
    Feb 14, 2015
    Posts:
    66
    Thanks all. I'll give this a try!
     
  5. kartoonist435

    kartoonist435

    Joined:
    Feb 14, 2015
    Posts:
    66
    Ok so I upgraded Unity to the version you mentioned, which got rid of my errors but now I can't build due to Gradle 5.6.4 not being part of Unity 2019.4.15f1. I then set the path of the gradle version to a 2020.2 location as this link says they are compatible gradle versions
    https://developers.google.com/ar/develop/unity/android-11-build
    but that doesn't work. This integration is very difficult is there a version that just works? Can I just start in 2020.2 without going through all this?
     
  6. kartoonist435

    kartoonist435

    Joined:
    Feb 14, 2015
    Posts:
    66
    I was able to get a build by just updating to 2020.2 and had to update a package or two but it seems to work now on my Android tablet. Thanks for the help.
     
    mtschoen and jmunozarUTech like this.
  7. mtschoen

    mtschoen

    Unity Technologies

    Joined:
    Aug 16, 2016
    Posts:
    146
    I'm glad you got it working! Sorry for the confusion. We're working on making this setup process easier.

    In case you run into this again, here's some more info on this issue https://forum.unity.com/threads/arc...uires-updated-gradle-on-unity-2019-4.1003444/

    Thanks again for using MARS and reaching out for help. Happy hacking! :)
     
unityunity