Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice
  3. Dismiss Notice

Camera FOV zoom is oddly culling objects

Discussion in 'General Graphics' started by mrVentures, Oct 3, 2021.

  1. mrVentures


    Nov 11, 2018
    When restrict my camera FOV, my skinned mesh renderer is getting culled. It doesn't make sense why this would be occurring. It happened with the Default Renderer.

    The clipping planes seem to not be the cause of the issue.

    Here is a gif that shows the renderer popping in and out when I change only the FOV:

    The mesh renderer settings (if relevant):

    Resizing the game window also can pop the rendering:

    "Update when Offscreen" did not have an impact on the behavior.
    Last edited: Oct 3, 2021
  2. bgolus


    Dec 7, 2012
    Those render bounds look … suspiciously small.

    First, why is this a skinned mesh? I suspect the answer is because you have it animate open from some folded up pose. I also suspect that folded up pose is off screen when it’s disappearing.

    I would try manually editing the render bounds so they cover the area the map is when fully open. My guess is that for some reason the bounds either we already edited to something tiny, or they’re just not getting updated for some reason by the animation. If you’re scaling bones, I think the bounds estimation isn’t great with those. If the bounds aren’t visible, neither will the mesh be, since the bounds are what the CPU side uses to determine if the GPU should be told to render something or not.

    A second suggestion is, if this mesh does not itself need to deform via bone animation, don’t use a skinned mesh renderer. Like if you’re using an animation to move an otherwise solid object around, use a regular mesh renderer attached to a bone.