Search Unity

  1. New Unity Live Help updates. Check them out here!

    Dismiss Notice

Camera Crash

Discussion in 'Editor & General Support' started by Eliasnd, Nov 15, 2017.

  1. Eliasnd

    Eliasnd

    Joined:
    Nov 14, 2017
    Posts:
    3
    I'm working on a new MacBook Air 2017. Unity was running totally fine until it started crashing every time I created an object or loaded a prefab. I was doing this in the tank tutorial at the time, and it still happened after multiple wipes and reinstalls. I've isolated the problem to the camera.

    If I delete the main camera, the editor runs totally fine, but with a main camera or any camera, whether it's created before or after the other objects, the camera view glitches out. Then the program, or sometimes my whole computer, will totally crash after freezing for 5-10 seconds. This happens in all tutorials and projects I make as well.

    Notes: I recently upgraded to Mac OS High Sierra. When reinstalling, I deleted the program folder, the folder in the Library, and the folder in Application Support. Could these be the source of the problem?
     
  2. joseibanez

    joseibanez

    Joined:
    Nov 18, 2017
    Posts:
    6
    I have the exact same issue with my MacBook Air 2015
     
  3. Eliasnd

    Eliasnd

    Joined:
    Nov 14, 2017
    Posts:
    3
    Could it be the release? Because mine was working fine before.
     
  4. joseibanez

    joseibanez

    Joined:
    Nov 18, 2017
    Posts:
    6
    I reported the bug to Unity and they were very helpful. Try opening the Player Settings, (Edit / Project Settings / Player Settings), opening the tab for "Other Settings", and checking the "Metal Editor Support" checkbox.

    My laptop doesn't crash now and it doesn't lag either. If that doesn't work for you, I suggest you report the bug using Unity Bug Reporter.
     
    nivek2696 and nemoyyteen like this.
  5. Yudjinn

    Yudjinn

    Joined:
    Nov 21, 2017
    Posts:
    1
    I had the same problem on my Macbook Pro. I downloaded the patch that was released today and now it's working just fine!
     
  6. tevi79

    tevi79

    Joined:
    Oct 18, 2012
    Posts:
    4
    I'm suffering the exact same issue. It appeared few days back out of nowhere with 2017.3.0.b9 and continues with b10 also. What I've found out is that it seems like if I disable vuforia support from XR Settings everything runs just fine. After enabling vuforia adding any kind of camera to the scene will crash the editor. If I build for the device (ios or android) everything is ok.

    I'm running Unity on MacBook Pro 2017.
     
  7. nemoyyteen

    nemoyyteen

    Joined:
    Jan 24, 2018
    Posts:
    2
    It works for me. thx a lot!
     
    joseibanez likes this.
  8. nemoyyteen

    nemoyyteen

    Joined:
    Jan 24, 2018
    Posts:
    2
    Hi~the answer in #4 that post by @joseibanez may solve your problem. U can try it
     
unityunity