Search Unity

Bug Burst error on GhostDistanceImportance.cs when building (1.2.0-pre.4)

Discussion in 'NetCode for ECS' started by XiangAloha, Feb 10, 2024.

  1. XiangAloha

    XiangAloha

    Joined:
    Jun 19, 2020
    Posts:
    21
    I am trying Distance-based Importance Scaling, and everything works very well. but when I tried to build client only for iOS, it gave me burst errors pointing to GhostDistanceImportance.cs(62,9). Previously when I was not using the feature, all the builts went successful. I am not sure if I missed something.

    I am using Unity 2022.3.16f1 (Silicon)
    - Burst 1.8.11
    - Entities 1.2.0-pre.4
    - NetCode 1.2.0-pre.4

    The error line
    Screenshot 2567-02-11 at 03.15.23.png
    Errors:
    Screenshot 2567-02-11 at 03.05.31.png
    Screenshot 2567-02-11 at 03.07.05.png Screenshot 2567-02-11 at 03.08.07.png Screenshot 2567-02-11 at 03.08.23.png

    An additional question if I may ask here. Do Distance-based Importance Scaling and Relevancy work together?
     
    Last edited: Feb 10, 2024
  2. CMarastoni

    CMarastoni

    Unity Technologies

    Joined:
    Mar 18, 2020
    Posts:
    894
    They work together and this looks like a problem with IOS/IL2CPP/AOT. Thanks for reporting. We will fix this sooner than asap.
     
  3. XiangAloha

    XiangAloha

    Joined:
    Jun 19, 2020
    Posts:
    21
    Hi, and thanks! Please let me know when the fix arrives!
     
  4. XiangAloha

    XiangAloha

    Joined:
    Jun 19, 2020
    Posts:
    21
    May I know is this fixed in 1.2.0-pre.12?