Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Question Building for Android problems with SDK versioning.

Discussion in 'Editor & General Support' started by tclancey, Jun 22, 2020.

  1. tclancey

    tclancey

    Joined:
    May 19, 2017
    Posts:
    143
    Hi there.

    I'm not an Android person so I'm not totally sure if this is an Android Studio issue, or Unity.

    I have a P40 on loan, nice enough phone, I have it working with Unity Remote (which NEEEDS much better instructions and help) and my test plays ok, a few resolution issues but I think those are fixable.

    I've just tried a test Build but I get the error SDK Tools version 0.0 < 26.1.1. with an update button which fails and returns to the same error.

    This is with the Preferences set to use the latest SDK downloaded with Android Studio which I have to do to use Remote.

    If in preferences I use the Unity SDK instead of the latest installed with Android Studio the project builds. To say this is confusing is an understatement. To test I have to use the Correct SDK, which isn't the correct SDK for building where I have to use the correct SDK? What?

    This either needs explaining somewhere in the Editor, or changing so the different operations use different settings. And I'd like to know why I've spent the time and disk place installing a load of Android stuff for the Remote when it's not any good for building apps. And then when I say download the latest why does this not work.

    So I guess my questions are:
    --What SDKs should I have installed and where?
    --What Preferences should I have set for building and remoting?

    This isn't at a rant, as I say I'm no Android person, but for someone starting out with Unity (me) this is particularly confusing.
    Many thanks.