Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Resolved Build succeeded, App installed to device. Not appearing or running on Oculus Quest 2

Discussion in 'VR' started by MiguelAmbrizFoxconn, Jun 16, 2023.

  1. MiguelAmbrizFoxconn

    MiguelAmbrizFoxconn

    Joined:
    Nov 2, 2022
    Posts:
    4
    Since Yesterday I'm trying to deploy my project to my Oculus Quest 2.
    When I play it from Unity it works well, I can test it via Quest Link and there is no problem, but when
    I hit the build and run it doesn't run or shows on my Unknown Sources from my Oculus Quest.

    I have no idea what Happened, I installed SideQuest and installed my apk from there, also
    with success but there is nothing on my Oculus.
    The OS version of Oculus is 54 and my Unity editor is 2021.3.21f1.
    I have no idea what else to do, I have activated ''enable developer mode'' from my Phone.

    What I noticed is that the App Library from Oculus is different now, before I could access the ''unknown sources'' from the main page but now I have to click on search and then select ''unknown sources''.
    But there is nothing there.

    I have this messages on the console:


    Application installed to device "1WMHHA40YD2013 [Quest 2]".
    UnityEngine.GUIUtility: ProcessEvent (int,intptr,bool&)

    Build completed with a result of 'Succeeded' in 20 seconds (20255 ms)
    UnityEngine.GUIUtility: ProcessEvent (int,intptr,bool&)


    Any idea of how to fix it? Quest Unity Screen.png
     
  2. korinVR

    korinVR

    Joined:
    Jul 7, 2012
    Posts:
    33
    The "Unknown Sources" apps has been moved to the back of the "Search apps" bar since the Quest software v54 update. Click on the search bar and pull down the "All" menu. It's quite confusing...
     
    Azirell, laurajhchen and Psykonaut like this.
  3. MiguelAmbrizFoxconn

    MiguelAmbrizFoxconn

    Joined:
    Nov 2, 2022
    Posts:
    4
    Thanks.
    I know where they are, but my build is not deploying even if I have the "succeeded" message. I can see the list and my app is not there. And when I hit build and run , it doesn't run.
    If I press the play button inside of Unity my game runs well with the cable.
    I'm searching everywhere on the web expecting to see more cases like mine but I'm no finding anything. Thanks again.
     
  4. MiguelAmbrizFoxconn

    MiguelAmbrizFoxconn

    Joined:
    Nov 2, 2022
    Posts:
    4
    I finally fixed it. I had to factory reset the Oculus.
    On this week while I was using them the screen became black and I couldn't do anything. Maybe at that time something on the system got corrupted and messed it up.
     
  5. soggyinkgames

    soggyinkgames

    Joined:
    Oct 4, 2021
    Posts:
    4
    it is currently on apps you need to click on the filter icon on the top right hand side then click the inner dropdown and select `unknown source` this will take you to your uploaded builds
     
  6. Evinewyork

    Evinewyork

    Joined:
    Dec 31, 2018
    Posts:
    5
    Same problem, I am using Unity 2023.1.1f, getting this error, followed by Succeeded. When in fact the app is not succeeded to install. (in fact, I WAS able to build it successfully to the device the first time I set up the project, nothing changed.)
    CommandInvokationFailure: Unable to install APK to device. Please make sure the Android SDK is installed and is properly configured in the Editor. See the Console for more details
    Build completed with a result of 'Succeeded' in 19 seconds (18545 ms)
    UnityEngine.GUIUtility:processEvent (int,intptr,bool&)


    It looks like lates Unity editors are just designed to make us fail building in VR, every editor comes with a huge number of issues.
     
  7. MiguelAmbrizFoxconn

    MiguelAmbrizFoxconn

    Joined:
    Nov 2, 2022
    Posts:
    4
    Thanks, I could see where the ''Unknown Sources'' were. Only my app was not there. I had to factory reset the Oculus and after that it worked again.