Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Resolved Build quality suddenly become lower than editor play mode

Discussion in 'Editor & General Support' started by ptzrzdfan1, Nov 30, 2023.

  1. ptzrzdfan1

    ptzrzdfan1

    Joined:
    Sep 18, 2023
    Posts:
    3
    Hi! I have a problem with my personal project. I suddenly get low quality in build. Before that, the build was looking the same as editor player. But now my builds are suddenly look not as good.

    - shadows look like shadow distance is very small (although it is set to 250 units)
    - all objects that have LODS appear culled much closer to the camera than before
    - reflection probes stopped working in Deferred mode

    But in the editor play mode, everything works as intended.

    I dont't understand why it happened. I tried clear build, reboot the computer, deleted the library folder.

    Before the problem appeared, I added and configured post processing layer component to the camera. But after I saw the changed build, I removed that component, but the problem didn't go away.

    Here is the image from today's build: build_1.jpg


    Here is the image from the editor play mode (this is how it should have been in the build) editor.jpg
    I use Unity 2022.3.9f1 with built-in renderer pipeline.

    Sorry for my English, its not my native language.

    Could anyone help? Thank you.
     
    Last edited: Dec 1, 2023
  2. ptzrzdfan1

    ptzrzdfan1

    Joined:
    Sep 18, 2023
    Posts:
    3
    Problem solved. Turned out that default quality setting somehow switched itself from ultra to very low.