Search Unity

  1. We are migrating the Unity Forums to Unity Discussions. On July 12, the Unity Forums will become read-only. On July 15, Unity Discussions will become read-only until July 18, when the new design and the migrated forum contents will go live. Read our full announcement for more information and let us know if you have any questions.

Bug Build failure: com.unity.inputsystem@1.5.0 + linux64 standalone + UNITY_SERVER + linux editor

Discussion in 'Input System' started by vincent_aurory, Mar 15, 2023.

  1. vincent_aurory

    vincent_aurory

    Joined:
    Mar 8, 2022
    Posts:
    4
    Given the conditions listed in the post title, build fails with the following callstack (abreviated):


    Your mono runtime and class libraries are out of sync.
    The out of sync library is: /opt/unity/Editor/Data/MonoBleedingEdge/lib/mono/unityjit-linux/System.dll
    When you update one from git you need to update, compile and install
    the other too.
    Do not report this as a bug unless you're sure you have updated correctly:
    you probably have a broken mono install.
    If you see other errors or faults after this message they are probably related
    and you need to fix your mono install first.
    Compressing using quality level 127
    Compressing using quality level 127
    mono_class_from_mono_type_internal: implement me 0x34
    * Assertion: should not be reached at class.c:2214
    Caught fatal signal - signo:6 code:-6 errno:0 addr:0x72
    Obtained 42 stack frames.
    #0 0x007fb50171e980 in funlockfile
    #1 0x007fb501359e87 in gsignal
    #2 0x007fb50135b7f1 in abort
    #3 0x007fb3dc88a7c5 in monoeg_assert_abort
    #4 0x007fb3dc873d06 in mono_dl_fallback_unregister
    #5 0x007fb3dc88aadd in monoeg_g_logv
    #6 0x007fb3dc88ac16 in monoeg_assertion_message
    #7 0x007fb3dc88ac5c in mono_assertion_message_unreachable
    #8 0x007fb3dc7a3e19 in mono_class_from_mono_type_internal
    #9 0x007fb3dc83889d in mono_type_get_object
    #10 0x007fb3dc83884b in mono_type_get_object
    #11 0x0056177e7f5e86 in scripting_class_get_object(ScriptingClassPtr)
    #12 0x0056177fd0c1e1 in AssetDatabase::CollectManagedImportDependencyGetters(AssetDatabase::AssetImporterSelection&, ArtifactKey const&)
    #13 0x0056177fdb2187 in AssetImportManager::Import(core::hash_map<AssetDatabase::ImporterID, ImporterInfo, core::hash<AssetDatabase::ImporterID>, std::equal_to<AssetDatabase::ImporterID> > const&, dynamic_array<PostprocessorInfo, 0ul> const&, AssetResolver&, CategorizedAssets&, IImportProgress*, core::hash_set<UnityGUID, core::hash<UnityGUID>, std::equal_to<UnityGUID> > const&, ImportedAssetsReloadList*, core::hash_set<core::basic_string<char, core::StringStorageDefault<char> >, core::hash<core::basic_string<char, core::StringStorageDefault<char> > >, std::equal_to<core::basic_string<char, core::StringStorageDefault<char> > > >&, CrashedAssetImportsDatabase&, OnDemandScheduler&, bool)
    #14 0x0056177fdda4e4 in RefreshInternalV2(AssetDatabase::UpdateAssetOptions, ScanFilter const&, InternalRefreshFlagsV2)
    #15 0x0056177fdb5bc5 in StopAssetImportingV2Internal(AssetDatabase::UpdateAssetOptions, InternalRefreshFlagsV2, ScanFilter const*, char const*)
    #16 0x0056177fdb80ce in RefreshV2(AssetDatabase::UpdateAssetOptions)
    #17 0x0056177fdc0df7 in VerifyAssetsForBuildTargetV2(AssetDatabase::CancelBehaviour, bool, bool)
    ...

    Similar issue: https://forum.unity.com/threads/cra...ld-on-linux-64-with-unity-2022-2-3f1.1391725/
     
    pojoih likes this.
  2. pojoih

    pojoih

    Joined:
    Mar 30, 2013
    Posts:
    228
    I thing I have the same problem here, did you figured something out? Weird thing seems to be the the build has succeeded but the docker return code is wrong just because of this message.

    I've opened an issue in the game CI repo but this seems like more of a unity on unix problem?
    https://github.com/game-ci/unity-builder/issues/535
     
  3. vincent_aurory

    vincent_aurory

    Joined:
    Mar 8, 2022
    Posts:
    4
    I ended up reverting the package version. Last time I checked, 1.5.0 was no longer accessible on the registry. I see that 1.5.1 is now available though. I haven't tried it yet.
     
  4. vincent_aurory

    vincent_aurory

    Joined:
    Mar 8, 2022
    Posts:
    4
    Just tried updating to Unity 2022.3.4f1 which specified using InputSystem version 1.6.1 and I encountered the same issue. Reverting to version 1.4.4 fixed it.