Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question Build Error for Hololens 2 BuilderFailedException: Lump_libil2cpp_os.cpp

Discussion in 'Windows' started by StarCoop, Aug 10, 2023.

  1. StarCoop

    StarCoop

    Joined:
    Nov 26, 2016
    Posts:
    44
    Hello guys, I want to deploy for Hololens 2 and I'm encountering an error I am ot able to resolve.
    upload_2023-8-10_10-45-51.png

    I've tried updating Unity to a different version to no avail. I'm using VS2019 and I do not have VS2022 installed. Below you can see the error output by visual studio.
    Is it possible that the referenced Windows 10 SDK is broken / the culprit? Should I specify a Target SDK Version or use the latest installed?

    Unity Version 2021.3.29f1
    Build settings:

    upload_2023-8-10_10-42-43.png

    Error Log:

    Any help would be greatly appreciated.
    Best regards,
    Phil
     
  2. StarCoop

    StarCoop

    Joined:
    Nov 26, 2016
    Posts:
    44
    I've set a different Target SDK since 10.0.22621.0 seems not to work.
    After changing the sdk and building again the error disappeared.
     
  3. Tautvydas-Zilys

    Tautvydas-Zilys

    Unity Technologies

    Joined:
    Jul 25, 2013
    Posts:
    10,628
    That's weird, lmcons.h should be in that same folder (it is on my machine at "C:\Program Files (x86)\Windows Kits\10\Include\10.0.22621.0\shared\lmcons.h"). If it's not there, I'd suggest reinstalling the Windows SDK, something went wrong with it.