Search Unity

Build 5.6.0xb6, Illegal instruction

Discussion in 'Linux Editor' started by Hoogin, Feb 4, 2017.

  1. Hoogin

    Hoogin

    Joined:
    Jul 27, 2015
    Posts:
    38
    When I try to launch the editor It says "Illegal instruction", I'm using the self extracting package.

    Anyone else have the same message?
     
  2. AurimasBlazulionis

    AurimasBlazulionis

    Joined:
    Aug 13, 2013
    Posts:
    209
    Are you sure you are running on amd64 architecture?
     
  3. Hoogin

    Hoogin

    Joined:
    Jul 27, 2015
    Posts:
    38
    Yeah, I can run 5.6.0xb3 fine.
     
  4. sylv1pdt

    sylv1pdt

    Joined:
    Feb 4, 2017
    Posts:
    5
    Same issue here with Debian Stretch 64bits (I'm sure :) )
    Version 5.6.0xb3 was working fine except the few known bugs.
    It might be useful to know that I use a quite old CPU : Core2Duo E6750
     
  5. AurimasBlazulionis

    AurimasBlazulionis

    Joined:
    Aug 13, 2013
    Posts:
    209
    Sometimes updating the microcode can fix this.
     
  6. Tak

    Tak

    Unity Technologies

    Joined:
    Mar 8, 2010
    Posts:
    951
  7. The-Britain

    The-Britain

    Joined:
    Mar 31, 2015
    Posts:
    714
    I will wait to update until I see the results of this. Thanks for the great work Tak, the Linux builds are coming fast and hard.
     
  8. sylv1pdt

    sylv1pdt

    Joined:
    Feb 4, 2017
    Posts:
    5
    Hi Tak,
    It seems the crash does not generate a core dump file, I don' know why...
    I compiled a test program with a segmentation fault, and got the core dump so I'm sure my terminal is set up correctly.

    If you have any suggestions, I will try them. If not, I hope Hoogin has more luck.
     
  9. sylv1pdt

    sylv1pdt

    Joined:
    Feb 4, 2017
    Posts:
    5
  10. Hoogin

    Hoogin

    Joined:
    Jul 27, 2015
    Posts:
    38
    Here is my core dump. Core dump link.
    I'm running an older cpu on this machine, AMD Phenom II x4 955.
     
    Last edited: Feb 6, 2017
  11. Tak

    Tak

    Unity Technologies

    Joined:
    Mar 8, 2010
    Posts:
    951
    Ok, it looks like one of our middleware libraries was built to use sse4.1 - we'll address that.
     
  12. LearningNot

    LearningNot

    Joined:
    Sep 30, 2015
    Posts:
    104
    i got same Illegal instruction (core dumped) but guess Taks on it :)
     
  13. sylv1pdt

    sylv1pdt

    Joined:
    Feb 4, 2017
    Posts:
    5
    Thanks :)
     
  14. Hoogin

    Hoogin

    Joined:
    Jul 27, 2015
    Posts:
    38
    Okay, Thanks Tak!
     
  15. FuzzyLuke

    FuzzyLuke

    Joined:
    Dec 6, 2012
    Posts:
    40
    I can subscribe to this problem too. Same thing happened to me.

    lucas@lucas-A780GM-A:/opt/Unity/Editor$ ./Unity
    Illegal instruction (core dumped)

    Uploaded the core file
     

    Attached Files:

    Last edited: Feb 7, 2017
  16. CzarnyBambus

    CzarnyBambus

    Joined:
    Sep 17, 2013
    Posts:
    1
    Please build it without sse4.1 requirement, I have Q6600 and it supports only sse3 :(
     
  17. dobrMAN

    dobrMAN

    Joined:
    Mar 18, 2015
    Posts:
    8
    Some issue...
     
  18. dobrMAN

    dobrMAN

    Joined:
    Mar 18, 2015
    Posts:
    8
    Anybody try use 5.6.0b8? It is steel have issue with Illegal instruction at processors without SSE4.1?

    This my system information:
    System: Host: dobrman-PC Kernel: 4.4.0-62-generic x86_64 (64 bit)
    Desktop: Cinnamon 3.2.7 Distro: Linux Mint 18.1 Serena
    Machine: Mobo: ECS model: A740GM-M v: 1.0
    Bios: American Megatrends v: 080014 date: 05/07/2010
    CPU: Triple core AMD Athlon II X3 440 (-MCP-) cache: 1536 KB
    clock speeds: max: 3000 MHz 1: 3000 MHz 2: 3000 MHz 3: 3000 MHz
    Graphics: Card: NVIDIA GF108 [GeForce GT 630]
    Display Server: X.Org 1.18.4 drivers: nvidia (unloaded: fbdev,vesa,nouveau)
    Resolution: 1920x1080@60.00hz
    GLX Renderer: GeForce GT 630/PCIe/SSE2
    GLX Version: 4.5.0 NVIDIA 378.13
     
    Last edited: Feb 19, 2017
  19. Tak

    Tak

    Unity Technologies

    Joined:
    Mar 8, 2010
    Posts:
    951
    Nothing has changed in this area - we're still working on getting new builds of the affected code.
     
    dobrMAN likes this.
  20. cwolcott

    cwolcott

    Joined:
    Feb 2, 2016
    Posts:
    1
    Looks like you guys are on it, but I also tried 5.6.0xb8 with the same illegal instruction error. The last version I tried, 5.1.0f3 worked fine. (I know, its old)

    Here's my hardware:

    charlie@samsung ~ $ inxi -F
    System: Host: samsung Kernel: 4.4.0-21-generic x86_64 (64 bit) Desktop: Cinnamon 3.2.7
    Distro: Linux Mint 18.1 Serena
    Machine: Mobo: SAMSUNG model: 305V4A/305V4A v: 02QN
    Bios: American Megatrends v: 02QN.MI99.20110908.SKK date: 09/08/2011
    CPU: Quad core AMD A6-3410MX APU with Radeon HD Graphics (-MCP-) cache: 4096 KB
    clock speeds: max: 1600 MHz 1: 1000 MHz 2: 800 MHz 3: 1300 MHz 4: 1000 MHz
    Graphics: Card: Advanced Micro Devices [AMD/ATI] BeaverCreek [Radeon HD 6520G]
    Display Server: X.Org 1.18.3 drivers: ati,radeon (unloaded: fbdev,vesa) Resolution: 1366x768@60.07hz
    GLX Renderer: Gallium 0.4 on AMD SUMO (DRM 2.43.0, LLVM 3.8.0) GLX Version: 3.0 Mesa 11.2.0


    By the way, THANK YOU for porting Unity to Linux!
     
  21. roecket

    roecket

    Joined:
    Feb 14, 2017
    Posts:
    1
    I have the same problems with 5.6.x. I'm tried 5.5.1xf1 and it works. Had not much time to look into it so can't say anything other than it starts =)
     
  22. phong-genix

    phong-genix

    Joined:
    Oct 28, 2015
    Posts:
    103
    Last edited: Feb 24, 2017
  23. phong-genix

    phong-genix

    Joined:
    Oct 28, 2015
    Posts:
    103
    I removed 5.6 and re-installed 5.5.1f1 and it worked for me.
     
  24. Jesper-Mortensen

    Jesper-Mortensen

    Unity Technologies

    Joined:
    Mar 15, 2013
    Posts:
    196
    We have a fix that will go into 5.6 final.
     
  25. Destructor83

    Destructor83

    Joined:
    Mar 10, 2017
    Posts:
    3
    Anybody can give me link to download 5.5.1f1 version? Because I've created project at work on Linux Mint 17.3 KDE and try to open this project on Lubuntu 16.10 at home but IDE crashes after click buttion "Open" when folder is choosen. IDE version is same at work and at home - 5.6.0b6
     
  26. Hoogin

    Hoogin

    Joined:
    Jul 27, 2015
    Posts:
    38
    Got an estimated release date on 5.6 final?
     
  27. Tak

    Tak

    Unity Technologies

    Joined:
    Mar 8, 2010
    Posts:
    951
  28. Destructor83

    Destructor83

    Joined:
    Mar 10, 2017
    Posts:
    3
    Yes I have already tried it but nothing changed. And last version 5.6.0b10 did not help me.
    May I help you to collect logs? I'll be glad to help you
     
  29. rinalds15

    rinalds15

    Joined:
    Jun 3, 2018
    Posts:
    1
    i have the error illegal instruction (core dumped) on latest unity 2018.1.2f1 on ubuntu 16.04 LTS