Search Unity

BUG: VR.WaitForGPU forcibly occupies CPU when running in background

Discussion in '5.5 Beta' started by John-Chen350, Oct 9, 2016.

  1. John-Chen350

    John-Chen350

    Joined:
    Jan 14, 2015
    Posts:
    53
    Maybe that's a 5.4 thing but 5.5 beta still has this 'feature'.. So I post here again.

    I'm working on a enterprise-level Unity3D project on OpenVR recently. Generally speaking it works great, yet when I send it into background (when other VR programs are running) Unity forcibly cooled FPS down to ~10. I've noticed that VR.WaitForGPU used ~100ms even if there are nothing being rendered. No active cameras.

    I know there are no needs for rendering to HMD when you are in background, but what if I need it to be in companion window while I cannot even toggle off VRSettings.enabled? (which definitely caused crash)

    In this situation, I have no way to improve framerate for now. Application.targetFrameRate did nothing. I need only the camera working for Main Display at this time, without removing the VR support altogether (which is needed earlier or later during life cycle)..

    Looking forward to your kind help, Unity Team :)
     
unityunity