Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

[BUG] Importer from 2017.4 to 2018.3b2/b4 failed on one prefab

Discussion in 'Prefabs' started by aurelien-morel-ubiant, Oct 10, 2018.

  1. aurelien-morel-ubiant

    aurelien-morel-ubiant

    Joined:
    Sep 27, 2017
    Posts:
    275
    Hello,
    we import all our project from 2017.4 to 2018.3 to test/use the new nested prefab system.
    And it seems to work well in 9/10 cases (hopefully).

    But we encountered a main issue with one of our prefab whereas this one seems to be equivalent to all others prefab we have.
    At the end of import process, we get thoses errors/warnings in the console :
    - CheckConsistency: GameObject does not reference component Canvas. Fixing.
    - Prefab “MenuIntelligentThing” has multiple roots.
    We’ve upgraded your prefab to work with the new nested prefab structure, but please verify that this is the behavior you intended to have.


    So I supposed the first error which quite incomplete (is triggered by the warning) cause we don't know which GameObject triggers this. We will have an improvement on this in a later beta ?
    But when I check the prefab before import process, there is no multiple roots so I don't know why the importing process in your 2018.3 triggered this, any idea ?

    And in our project hierarchy the prefab looks like this since unity 2018.3b4 :
    upload_2018-10-10_11-15-5.png


    Thanks for any answer we could obtain on this.
    Aurélien.
     
    Last edited: Oct 10, 2018
  2. aurelien-morel-ubiant

    aurelien-morel-ubiant

    Joined:
    Sep 27, 2017
    Posts:
    275
    Just a fast reply to let you know our progress one this one.
    When we check the MenuIntelligentThing.prefab in unity 2018.3bX it seems there is no prefab entitlement in the file as you can find in prefab file (obviously).
    so we check in our prefab file in 2017.X and there is no entitlement too in this version... but it didn't fail in 2017 (which is maybe already an issue even if it's nice cause it's avoid a bug :p).

    So, does Unity 2018 must be able to re-add this entitlement or is it exist a solution to fix it our self ?