Search Unity

  1. Unity 2018.3 is now released.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. Want more efficiency in your development work? Sign up to receive weekly tech and creative know-how from Unity experts.
    Dismiss Notice
  4. Build games and experiences that can load instantly and without install. Explore the Project Tiny Preview today!
    Dismiss Notice
  5. Nominations have been announced for this years Unity Awards. Celebrate the wonderful projects made by your peers this year and get voting! Vote here!
    Dismiss Notice
  6. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  7. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

ProBuilder Bug - Doesn't remember that UVs were set to Manual mode

Discussion in 'World Building' started by Tenebrous, Dec 1, 2018.

  1. Tenebrous

    Tenebrous

    Volunteer Moderator Moderator

    Joined:
    Jul 25, 2011
    Posts:
    99
    Editing UVs in manual mode works perfectly, but if you reload a scene that has them set to manual, they are back to auto. Any adjustments to the model then cause the UVs to be regenerated and your manual adjustments are lost.

    This also applies when you make a prefab, the UVs are instantly recalculated and the manual settings are lost.
     
  2. gabrielw_unity

    gabrielw_unity

    Unity Technologies

    Joined:
    Feb 19, 2018
    Posts:
    230
    Hi! I've checked and repro'd this, sorry for the trouble, will get it fixed and into the 4.0 release for sure! Thanks for the headsup! :)
     
  3. Tenebrous

    Tenebrous

    Volunteer Moderator Moderator

    Joined:
    Jul 25, 2011
    Posts:
    99
    Just seen it's fixed in preview 34, excellent job, thanks!
     
    gabrielw_unity likes this.