Search Unity

  1. Unity 2019.1 beta is now available.
    Dismiss Notice
  2. The Unity Pro & Visual Studio Professional Bundle gives you the tools you need to develop faster & collaborate more efficiently. Learn more.
    Dismiss Notice
  3. We're looking for insight from anyone who has experience with game testing to help us better Unity. Take our survey here. If chosen to participate you'll be entered into a sweepstake to win an Amazon gift card.
    Dismiss Notice
  4. On February 28th the Feedback website will shut down and be redirected to the Unity forums. See the full post for more information.
    Dismiss Notice
  5. Want to provide direct feedback to the Unity team? Join the Unity Advisory Panel.
    Dismiss Notice
  6. Unity 2018.3 is now released.
    Dismiss Notice
  7. Improve your Unity skills with a certified instructor in a private, interactive classroom. Watch the overview now.
    Dismiss Notice

BufferListProxyProperty.cs(82,25): error CS0411

Discussion in 'Entity Component System and C# Job system' started by illinar, Jan 13, 2019.

  1. illinar

    illinar

    Joined:
    Apr 6, 2011
    Posts:
    493
    Library\PackageCache\com.unity.entities@0.0.12-preview.21\Unity.Entities.Properties\ProxyProperties\BufferListProxyProperty.cs(82,25): error CS0411: The type arguments for method 'IPropertyVisitor.BeginCollection<TContainer, TValue>(TContainer, VisitContext<IList<TValue>>)' cannot be inferred from the usage. Try specifying the type arguments explicitly.

    Library\PackageCache\com.unity.entities@0.0.12-preview.21\Unity.Entities.Properties\ProxyProperties\BufferListProxyProperty.cs(110,21): error CS0411: ...



    New project. Copied code from another project, installed Entities, getting these errors. Although everything works.
     
  2. zorakbane

    zorakbane

    Joined:
    Jan 27, 2019
    Posts:
    1
    Same but with new project and no scripts whatsoever other than Entities, Job System, and Burst with the Profiler fix in manifest
     
  3. Ospa

    Ospa

    Joined:
    Nov 27, 2012
    Posts:
    9
    Make sure you install 0.2.11-preview version of the Property API.

    If you can't see it in the Package Manager, then add
    "com.unity.properties": "0.2.11-preview"
    to the dependencies in Packages/manifest.json
     
    illinar likes this.