Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Broken project: either doesn't load, or builds EVERYTHING PINK

Discussion in 'Editor & General Support' started by Lohoris2, Sep 28, 2017.

  1. Lohoris2

    Lohoris2

    Joined:
    Aug 20, 2013
    Posts:
    85
    My main project of mine has just broken and I have absolutely zero clue why.

    First it just failed to load at all: as soon as I selected it from the load screen, just nothing happened: no "this is loading, this is updating" little window: nothing at all.

    After many useless tries, including re-downloading the project from scratch, I re-installed the Unity Editor.

    After re-installing, the project loaded, and it worked in-editor. But in builds, everything was pink. Just a pink screen and that's it. No sound. However behind the pinkness, I think the game was still somewhat responsive. Difficult to say, since it was just pink.

    Re-importing the assets did nothing.

    Now it again completely fails to load, and that's it.

    Editor-prev.log ends like this:

    ----- Total AssetImport time: 0.081435s, AssetImport time: 0.048692s, Asset hashing: 0.000000s [0 B, 0.000000 mb/s]

    Refresh: detecting if any assets need to be imported or removed ... Refresh: elapses 0.010171 seconds (Nothing changed)
    Cleanup mono
    debugger-agent: Unable to listen on 63
    [usbmuxd] Stop listen thread
    [usbmuxd] Error:
    [usbmuxd] Listen thread exiting
    Callback unregistration failed. Callback not registered.

    (Filename: /Users/builduser/buildslave/unity/build/Runtime/Core/Callbacks/CallbackArray.h Line: 192)

    Checking for leaked weakptr:
    Found no leaked weakptrs.
    ##utp:{"type":"MemoryLeaks","allocatedMemory":1376634,"memoryLabels":[{"Default":3988},{"Permanent":16768},{"Thread":648},{"Manager":2704},{"VertexData":11376},{"Texture":96},{"Shader":293760},{"TextureCache":-96},{"Physics":8},{"Serialization":15712},{"JobScheduler":144},{"BaseObject":5484},{"Terrain":224},{"STL":8192},{"String":99140},{"DynamicArray":20044},{"Curl":176},{"PoolAlloc":-224},{"ScriptManager":13080},{"Sprites":659912},{"CloudService":296},{"WebRequest":7444},{"VR":7796},{"EditorGui":332},{"EditorUtility":544},{"AssetImporter":2432},{"RestService":64},{"License":574},{"UnityConnect":9232},{"WebViewCallback":6192},{"Collab":190592}]}


    Editor.log ends like this instead:

    Loading native library: UnityEditor.iOS.Native at /Applications/Unity 2017.1.0/PlaybackEngines/iOSSupport/UnityEditor.iOS.Native.dylib
    [usbmuxd] Start listen thread
    [usbmuxd] Listen thread started
    [usbmuxd] Send listen message
    Native extension for iOS target not found
    Native extension for Android target not found
    Begin MonoManager ReloadAssembly
    Shutting down Remote Indexer
    Task failed: Downloader Task
    Cancelling tasks, domain is going down


    I'm using 2017.1.1.

    I also tried with 2017.1.0 but nothing relevant changes: I select the project, I get (as expected) the "non matching editor window", and as soon as I hit "continue" it just hangs.

    === Update 1 ===

    I've read someone suggesting to start offline. Indeed when I tried to work offline the project started.
    I don't know if that is the reason, but it's pretty odd if it is, since it happens only with that project.

    === Update 2 ===

    When it does work (i.e. it's pink, instead of just not starting), I get these logs among the others:

    <i>OSXPlayer(Gnaw)</i> Unsupported: 'Hidden/VideoDecodeOSX' - Pass 'FLIP_RGBARECT_TO_RGBA' has no vertex shader

    <i>OSXPlayer(Gnaw)</i> Unsupported: 'Hidden/VideoDecodeOSX' - Setting to default shader.


    Obviously zero clue what they are talking about: I don't do shaders, and I certainly didn't modify anything related to them today.

    === === === ===

    I am completely clueless about what to do now, I'm stuck and I can't work any more.
     
    Last edited: Sep 28, 2017
  2. Lohoris2

    Lohoris2

    Joined:
    Aug 20, 2013
    Posts:
    85
    In a test scene I got this:



    Seriously, what's going on?!?
     
  3. Lohoris2

    Lohoris2

    Joined:
    Aug 20, 2013
    Posts:
    85
    This comment finally solved it.

    Why I had this problem also when re-downloading the project from scratch, I still have zero clue.