Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Brand new to Unity, downloaded 2D Game Kit and got an error

Discussion in 'Getting Started' started by SpikeyBiscuit, Feb 25, 2020.

  1. SpikeyBiscuit

    SpikeyBiscuit

    Joined:
    Feb 25, 2020
    Posts:
    2
    upload_2020-2-25_14-15-51.png
    I opened it up and it said something like "error on first load. There should not have been one, go to the forums"
    I have no idea what didn't work or what I should be seeing as this is my very first time dealing with Unity. What do I do?

    After closing the error pop-up I noticed at the bottom it says "Import parameters got modified during import" Is that the issue?

    Thank you
     
    Benyamin_ likes this.
  2. SpikeyBiscuit

    SpikeyBiscuit

    Joined:
    Feb 25, 2020
    Posts:
    2
    I closed it without saving because I didn't want to save an error. Went through the steps again and ended up downloading and opening it a second time
    upload_2020-2-25_14-39-40.png
    This is the same screen I had the first time. Got no idea what is going on
     
  3. oleary757

    oleary757

    Joined:
    Feb 26, 2020
    Posts:
    2
    I'm in the same situation.

    edit:
    After playing around a bit, I built and ran the program. It worked.

    I came back to unity, in the console tab, and pressed clear on build and clear on play which cleared the error. I'm back to following the tutorial.

    Hope this helps.

    Edit 2:
    Back in the tutorial, I'm not able to get the new scene to show in the folder nor draw from the palette. Hopefully, someone with more knowledge can let us know what's wrong. Off to work, but I'll check back to see if anyone answers or if you figured anything out.
     
    Last edited: Feb 26, 2020
  4. UnityMaru

    UnityMaru

    Community Engagement Manager Unity Technologies

    Joined:
    Mar 16, 2016
    Posts:
    1,227
    Could you folks try loading the project in 2019.2? I see from the screenshot that you're in 2019.3 and according to the landing page (https://learn.unity.com/project/2d-game-kit), the project doesn't support that version.
     
  5. oleary757

    oleary757

    Joined:
    Feb 26, 2020
    Posts:
    2
    I'm unable to load it with 2019.2 from the HUB. It says I need to load 2019.3 to load this program. Note: it shows downloaded in the HUB. Is there a way to remove it from the HUB so I can download it to .2? Thanks
     
  6. d3ny0

    d3ny0

    Joined:
    Mar 11, 2020
    Posts:
    1
    I have the same problem as SpikeyBiscuit... does anyone has a solution for this?

    I've already deinstalled Unity, Unity Hub and deleted all the folders of Unity in the %appdata% directory. Downloaded/installed everything again. Sadly, that doesn't helped.
     
  7. unity_jxHX9TWnbNlB_w

    unity_jxHX9TWnbNlB_w

    Joined:
    Mar 18, 2020
    Posts:
    1
    Same here but with the Begginer Code project. "Import parameters got modified during import" errors and I can't fix it. I tried to uninstall and install everything, download the project again, etc... no luck
     
  8. Takis

    Takis

    Joined:
    Feb 2, 2020
    Posts:
    10
    Since the "preferred version" feature got removed I don't see a way to open a tutorial (unity learn) project with a specific version. In another post a Unity Team Member explained why the "preferred version" was removed and he said that there is no reason to open a tutorial project with a version other than the last installed. But actually there is a reason for this. The latest version I have is 2019.3 but the tutorial project "2D Game Kit" supports 2017.3 to 2019.2. So I most definitely need to select version while opening a tutorial project. Every version manager program should always allow to change the version to open/create a new project. Plz help. I am that close to uninstall 2019.3
     
  9. hollowthreat

    hollowthreat

    Joined:
    Mar 23, 2020
    Posts:
    2
    Same error here "Import parameters got modified during import" , trying unity for the first time, this is not a good experience :(
    Can't find 2019.2 in HUB, lowest is 2019.3 which is what I've installed. Unity team aware of this problem? how do we report this issue?
     
  10. UnityMaru

    UnityMaru

    Community Engagement Manager Unity Technologies

    Joined:
    Mar 16, 2016
    Posts:
    1,227
    Thanks for the heads up folks. I've asked the content team to look into this so either myself or them will update once we have more news.
     
    hollowthreat likes this.
  11. Takis

    Takis

    Joined:
    Feb 2, 2020
    Posts:
    10
    I've played a bit with Unity before. It's a great tool but this hickup is indeed not good. It's not a problem with the actual tool though. Anyway here https://unity3d.com/get-unity/download/archive you can find "Unity 2019.2.0". Just select the "Unity Hub" option.
     
  12. Takis

    Takis

    Joined:
    Feb 2, 2020
    Posts:
    10
    The quickest solution, until a proper solution is found, would be to update "2D Game Kit" to be compatible with 2019.3. If you go down this road please also update "Ruby's Adventure: 2D Beginner". Both of them are part of the "Beginning 2D Game Development" and both support the same Unity versions. So I guess both would have the same issue. Thanks.
     
    Neto_Kokku likes this.
  13. BoeufHomard

    BoeufHomard

    Joined:
    Mar 24, 2020
    Posts:
    4
    Hello, I have the same situation here, I'm new to Unity, and I can't start the tutorials (creator kit : Puzzle for me). Is there any updates on this issue ? And how can I download 2019.2 ? I haven't managed too find it.
    Thanks

    Edit : Thanks Takis for the link for 2019.2
     
  14. Takis

    Takis

    Joined:
    Feb 2, 2020
    Posts:
    10
    Check my reply to another user in this thread. It's a couple of posts above :). Did it help you?
     
  15. BoeufHomard

    BoeufHomard

    Joined:
    Mar 24, 2020
    Posts:
    4
    Yes sorry, I had not seen your post, thanks, I will update you if it works.
     
  16. Takis

    Takis

    Joined:
    Feb 2, 2020
    Posts:
    10
    No worries
     
  17. BoeufHomard

    BoeufHomard

    Joined:
    Mar 24, 2020
    Posts:
    4
    So I have installed 2019.2.0, but then it showed me this, I can't launch the tutorial. So I tried with 2019.3.0 (so not the latest), but I got the same result than before.
    Did you manage to launch creator kits with 2019.2.0 ? From the unity hub it looks like 2019.3 or above is mandatory, which is a problem.
     

    Attached Files:

  18. hollowthreat

    hollowthreat

    Joined:
    Mar 23, 2020
    Posts:
    2
    Thanks for the reply, BoeufHomard tested not working, I've tried 2018.4.19f1 from HUB, still not working, it ask for 2019.3 to open the project o_O

    Guess I'll wait for unity's fix....
     
  19. BoeufHomard

    BoeufHomard

    Joined:
    Mar 24, 2020
    Posts:
    4
    So, I found a tutorial on YouTube that look complete, and even if it's not the latest version, there is a lots of recents comments that give a lots of advices, I am following this tutorial on the 2018.4.19 version (LTS).
    I thought you might be interested.
     
  20. Takis

    Takis

    Joined:
    Feb 2, 2020
    Posts:
    10
    No we are all in the same deadlock. Waiting for a fix for now.
     
  21. Takis

    Takis

    Joined:
    Feb 2, 2020
    Posts:
    10
    That's great. I will watch it. Thanks :)
     
  22. Takis

    Takis

    Joined:
    Feb 2, 2020
    Posts:
    10
    Exactly. BoeufHomard send a tutorial from youtube. Perhaps you can flex your muscles with this one while waiting.
     
  23. RaffoSFX

    RaffoSFX

    Joined:
    Apr 5, 2020
    Posts:
    1
    So? Any news about this issue?
     
  24. extarlife

    extarlife

    Joined:
    Apr 10, 2018
    Posts:
    2
    I'm also having issues with the beginner code project the assets are pink and there are numerous import warnings.

    I've tried deleting the project files etc from app data and re-downloading same issue when I try and open in latest 2019.3.9f1.
     

    Attached Files:

    colorus7 likes this.
  25. santosenoka

    santosenoka

    Joined:
    Apr 15, 2020
    Posts:
    1
    I'm having the same issues as everyone else. Any fix?
     
  26. UnityMaru

    UnityMaru

    Community Engagement Manager Unity Technologies

    Joined:
    Mar 16, 2016
    Posts:
    1,227
    Is everyone here reporting issues using version 1.9.1 of the 2D Game Kit?
     
  27. wolfgangbingo

    wolfgangbingo

    Joined:
    Feb 9, 2020
    Posts:
    1
    found this on another thread from a user called g3tinmyb3lly:

    In unity editor: Click Window, select package manager. Then select Universal RP and update to 7.3.1

    seems to have worked so far.
     
    zxonline likes this.
  28. DevShinoi

    DevShinoi

    Joined:
    Apr 15, 2020
    Posts:
    1
    @wolfgangbingo, updating the Universal RP worked for me, thanks buddy
     
  29. varzdani

    varzdani

    Joined:
    Apr 19, 2020
    Posts:
    1
  30. UnityMaru

    UnityMaru

    Community Engagement Manager Unity Technologies

    Joined:
    Mar 16, 2016
    Posts:
    1,227
    What version of the Editor are you using?
     
  31. Nollix

    Nollix

    Joined:
    Apr 21, 2020
    Posts:
    1
    Bless, fixed my issue with the beginner code tutorial
     
  32. badran08

    badran08

    Joined:
    Apr 3, 2020
    Posts:
    1
    For me it did not :(
     
  33. Zafus

    Zafus

    Joined:
    Sep 7, 2018
    Posts:
    2
    HI UNITY Developers:

    I am having trouble getting started with 2D GameKit Walkthrough. When I downloaded the project and opened it, followed through the instruction but all of my scenes are blur. I have attached the screenshot as well. I am using UNITY on MAC. I don't have much prior experience with UNITY so your help will be much appreciated. Thank You.

    It gave me same error:
    Import parameters got modified during import

    P.S All of my scenes are BLUR like the attached screenshot.

    Screenshot 2020-05-30 at 9.20.50 AM.png
     
  34. Valjuin

    Valjuin

    Joined:
    May 22, 2019
    Posts:
    481
    upload_2020-5-30_12-30-41.png
     
  35. Deleted User

    Deleted User

    Guest

    Hi! yesterday I reported that error. You can vote for it on Unity Issue Tracker:

    https://issuetracker.unity3d.com/is...hen-opening-up-the-project-for-the-first-time
     
  36. HeavyRudyUniUS

    HeavyRudyUniUS

    Joined:
    Sep 13, 2020
    Posts:
    1
    Could you please be more specific about the version you mean?, I don't know if I should try 2019.2.3 or 2019.2.4 or ... 2019.2.11 : / :confused::(
     
  37. Joe-Censored

    Joe-Censored

    Joined:
    Mar 26, 2013
    Posts:
    11,825
    I would first try 2019.2.0, as that is probably what it was uploaded using.
     
  38. n3phylum

    n3phylum

    Joined:
    Jan 9, 2017
    Posts:
    1
    I had the same "Import parameters got modified during import" issue. I'm using Unity 2020.1 with URP project.
    My solution was to go to Edit>Project Settings... and reset a URP settings (1st option) by just picking one as below screenshot.
    It doesn't appear to be a Unity issue but the imported asset settings.
    Hope this helps someone.

    upload_2020-9-26_19-46-10.png
     
    MichaelNielsenDev likes this.
  39. braunma

    braunma

    Joined:
    Apr 22, 2020
    Posts:
    1
    Similar issue here.
    - Downloaded 3D Beginner: Tutorial Resources (Supported Unity versions: 2018.3.6 or higher)
    - Unity Hub says about John Lemon's Haunted Jaunt: 3D Beginner "Editor version 2020.1"
    - Tutorial description supported until version 2019.4
    - I am using 2020.1.10f1
    The console throws me the following errors. upload_2020-10-25_21-22-38.png
    I have not done anything except downloading the tutorial resources. Any help?
     
  40. ljdfd

    ljdfd

    Joined:
    Dec 27, 2020
    Posts:
    1
    follow me, Click Window, select package manager. Then select Universal RP and update to 7.5.2,click console-->clear,run again ,start to work,hhhhhhh...
     
  41. MichaelNielsenDev

    MichaelNielsenDev

    Joined:
    Apr 17, 2014
    Posts:
    10
    Same issue here. On version 2019.4 in a new project I tried installing the John Lemon's Haunted Jaunt (first tried the resources version, ran into this issue and scrapped everything, then tried the complete project version in another new project with the same result).

    I keep getting errors that seem related to the package manager import failing somehow and always get the "Import parameters got modified during import" error last in the console list. I figured since the project has dependencies (on at least Cinemachine from what I can tell) I tried updating Cinemachine to the latest version via the Package Manager. Still got lots of errors including some warning about something wrong with a stylesheet or something.

    I tried also installing/updating the Universal Render Pipeline but still no go. Tried deleting and regenerating the Library and then updating the Package Manager itself to version 2 but still getting these errors. Any ideas? I'd really like to use the assets from this project to quickly prototype :/
     

    Attached Files:

    Last edited: Feb 8, 2021
  42. Sir_Ven

    Sir_Ven

    Joined:
    May 20, 2020
    Posts:
    1
    did that to me on the beginning code tutorial. went to >assets > reimport all
     
unityunity