Search Unity

Bored of constant crashes on PC when press play. Please update unity

Discussion in 'Editor & General Support' started by hippocoder, Jul 31, 2011.

  1. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    26,201
    Hi guys,

    Please make the editor crash bug on PC go away, I am sure you have had plenty of reports now, and it's a show stopper so a small point release update to fix this soon, and just this issue alone, would be fine as it does ruin ones work to lose it, and saving every 2 minutes isn't fun.

    Something this commonplace shouldn't have made it into the final release. Get your guys developing on PCs a little more often :)
     
  2. larvantholos

    larvantholos

    Joined:
    Oct 29, 2009
    Posts:
    668
    On the off chance it is this... Are you running windows, with Data Execution Protection enabled? If so, add an exception for unity, and windows will stop crashing it >..> Its been stable for this pc user there might be less reports than you think ;)
     
  3. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    26,201
    Its crashing anywhere up to every attempt from no attempts for an hour and so on, totally random behaviour and it doesn't care what project is running.

    I'm on the mac at the moment, will be trying this data protection stuff soon. I suspect it's something to do with 64 bit changes if any they've added.
     
  4. windexglow

    windexglow

    Joined:
    Jun 18, 2010
    Posts:
    378
    I am also experiencing this quite often, windows 7 64bit. Since 3.4 crashing has skyrocketed for me, I'm lucky if I don't get 2 ctd on play/build an hour.
     
  5. U7Games

    U7Games

    Joined:
    May 21, 2011
    Posts:
    943
    Weird, i have windows 7 64bits, and until now, i don´t have crash problems, (just 2 times crashed no more than that)..
    what is your computer spec?. i have a laptoc, aser 4740, core i5, intel gma hd 3 gb ram ddr3..
     
  6. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    26,201
    4 gig quad core intel, windows 7 64 bit, gforcr 460. All patched, legal and up to date of course.
     
  7. br0kenp0ly

    br0kenp0ly

    Joined:
    Jun 3, 2008
    Posts:
    481
    This sounds very strange indeed! Been running 3.4 just fine on all my windows machines so far.

    I`ll bug QA about it tomorrow!
     
  8. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    26,201
    Thank god. I have sent a few crash reports from the automated thing, but since then I just cancel them, I don't figure there's any point in enclosing my project either as it will happen just fine with Angrybots project too if I keep pressing play then stop then play, 100% crash chance.

    After the 3rd crash report I stopped sending them. Really hope its something that gets fixed though. Going to try the exception trick.
     
  9. U7Games

    U7Games

    Joined:
    May 21, 2011
    Posts:
    943
    Surely there is some kind of compatibility´s fault with some hardware in this version, but the most probably is Unity team will fix it soon in next release before 3.5 ...
     
  10. SomeGuy22

    SomeGuy22

    Joined:
    Jun 3, 2011
    Posts:
    576
    This is why, even though I have a mac, I don't update Unity unless there's a big change that drastically effects me.
     
  11. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    26,201
    Update: I changed DEP from "Turn on DEP for essential windows programs and services only" to "turn on DEP for all programs and services except those I select" and added Unity Editor. Now unity won't even start. It crashes every time on startup.

    This must be the problem somehow. I'd like to disable DEP for the entire OS if possible.
     
  12. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    26,201
    Next update, I disabled DEP for the entire OS and it seems to be stable at present, will let you know further. Thanks to the tip from larvantholos - we will see if it still happens.
     
  13. zine92

    zine92

    Joined:
    Nov 13, 2010
    Posts:
    1,347
    Hmm. Personally for me, i wait for the scripts to compile finish before hitting the play button. Back in unity 3.3 i could hit play while it is compiling but now i wait for it to finish before i hit play. I might try the dep thing too. Not sure if it will make me crash free. :D

    Posted this for people looking for how to disable dep.
     
  14. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    26,201
    I can get this crashing just by hitting play and stop repeatedly. Compiling scripts has little to do with it. Instead of running a 3rd party app all you need is this:

    http://www.mydigitallife.info/disab...ta-execution-prevention-dep-in-windows-vista/

    And then reboot (works on win7 64 bit too). So far no crashes but I'm not counting my chickens just yet.
     
    Last edited: Aug 1, 2011
  15. shawn

    shawn

    Unity Technologies

    Joined:
    Aug 4, 2007
    Posts:
    551
    Hey all! This is a known issue. We're looking into it :)
     
    Last edited: Aug 1, 2011
  16. hippocoder

    hippocoder

    Digital Ape Moderator

    Joined:
    Apr 11, 2010
    Posts:
    26,201
    Thank goodness :)
     
  17. Tiles

    Tiles

    Joined:
    Feb 5, 2010
    Posts:
    2,474
    Is it out yet? Is it out yet? Is it out yet? Is it ... :)
     
  18. zine92

    zine92

    Joined:
    Nov 13, 2010
    Posts:
    1,347
    When it's out it's going to be out. I don't wanna rush them this time round. Guess rushing won't work. I want a stable Unity instead. :D
     
  19. WillBellJr

    WillBellJr

    Joined:
    Apr 10, 2009
    Posts:
    394
    Well adding Unity to the DEP list saved me for v3.3, now with v3.4, I get no joy all the way around. I can't even start v3.4 at this point.

    Glad to see its being addressed, I guess back to v3.3 for me, fortunately I have a system snap shot (TODO backup manager) - I'll roll back to v3.3 until I hear there's a fix...

    -Will
     
  20. windexglow

    windexglow

    Joined:
    Jun 18, 2010
    Posts:
    378
    Great news.

    Windows 7 64bit, amd phenom x4 9550, nvidea gtx 260.
     
  21. Stephan-B

    Stephan-B

    Unity Technologies

    Joined:
    Feb 23, 2011
    Posts:
    2,269
    Waiting for this to get fixed before switching over to 3.4.
     
  22. reissgrant

    reissgrant

    Joined:
    Aug 20, 2009
    Posts:
    726
    win 7 64bit no issues here whatsoever. I have not enabled DEP on this verison yet though I have on past versions FWIW
     
  23. arioch82

    arioch82

    Joined:
    Dec 3, 2009
    Posts:
    255
    win7 64 bit it crashes also during the editing!

    i've just lost almost a full day of work!

    I've edited several prefabs, settings applied, scenes saved, moved between several scenes, played in the editor all day...

    now the editor crashed and all the prefabs are back to the initial status like i haven't applied any modification!

    you should really write somewhere that you have to click on "File->Save Project" and that saving the scenes or just applying the settings to prefabs is useless in this case as they aren't saved!
     
  24. Mingo

    Mingo

    Joined:
    Nov 14, 2010
    Posts:
    39
    Disabling DEP globally can result in a non-working system in some situations, so I really would not advise doing that without a complete image backup of your drive.
     
  25. zine92

    zine92

    Joined:
    Nov 13, 2010
    Posts:
    1,347
    I think you could enable back dep by going into safe mode.
     
unityunity