Search Unity

Border between object and shadow using MSAA

Discussion in 'Editor & General Support' started by Nition, Jan 13, 2013.

  1. Nition

    Nition

    Joined:
    Jul 4, 2012
    Posts:
    745
    When using standard MSAA in the Unity quality settings, with forward rendering, I'm getting a 1px white border between my object and its shadow. Has anyone else encountered this and solved it? Changing shadow settings doesn't help. This is on a Radeon 5850.

    I've found other posts about similar white borders, but those ones appear between polygons and were related to using a specular shader. Changing my shader to diffuse makes no difference, and neither does implementing the specular shader fix found in those threads (the o.Normal = fixed3(0,0,1); line). This seems to be a similar but different problem.

     
    Last edited: Jan 13, 2013
  2. krillmcrawl

    krillmcrawl

    Joined:
    Feb 18, 2011
    Posts:
    29
    I have the exact same thing, both on Nvida cards and on Radeon cards. Did you find any fix for it?

    Regards,

    Kristian
     
  3. Nition

    Nition

    Joined:
    Jul 4, 2012
    Posts:
    745
    Nope, sorry. :( At least I'm not the only one.
     
  4. krillmcrawl

    krillmcrawl

    Joined:
    Feb 18, 2011
    Posts:
    29
    Well, I really need a fix for this. Did you send a bug report?

    Regards,

    Kristian
     
  5. OutCyder

    OutCyder

    Joined:
    Mar 19, 2009
    Posts:
    2,154
    Man it's not that important, believe it or not, it's professional deformation: you notice it because you are doing your work, but 99% people don't give a damn about sparse pixels.
    Sure, it would be better if they weren't there, but believe me, you can continue your work and if it will be fixed, ok, otherwise, it's ok anyway for your public.
     
  6. Nition

    Nition

    Joined:
    Jul 4, 2012
    Posts:
    745
    I have submitted a bug report, yes. MegMaltese, I know what you mean, but I'd still like to fix it!
     
  7. krillmcrawl

    krillmcrawl

    Joined:
    Feb 18, 2011
    Posts:
    29
    megmaltese, point taken! However we run on 75 inch tv's where you stand 2 meters from. The pixels are not that small anymore:) And it's still a bug and should be dealt with at some point.

    Nition , have you saved the bug number so I can refer to the same one when submitting mine?

    Regards,

    Kristian
     
    Last edited: Mar 18, 2013
  8. Nition

    Nition

    Joined:
    Jul 4, 2012
    Posts:
    745
    Bug number is 533079.

    Can you switch to FXAA or similar for now to get around it? I only have the problem because I let the player choose which AA setting they want. If you can, just turn off AA in the quality settings and apply an AA post-processing image effect instead.
     
  9. Nition

    Nition

    Joined:
    Jul 4, 2012
    Posts:
    745
    You might be pleased to know that Unity QA has told me they can reproduce this issue and have sent it through to the devs, so we might see a fix yet.
     
  10. krillmcrawl

    krillmcrawl

    Joined:
    Feb 18, 2011
    Posts:
    29
    Nition, that sounds great!
     
  11. TacticalDan

    TacticalDan

    Joined:
    Jan 1, 2013
    Posts:
    35
    I await a solution as well.
     
  12. B0M

    B0M

    Joined:
    Jun 22, 2017
    Posts:
    5
    To this day it still hasn't been fixed.
     
  13. Nition

    Nition

    Joined:
    Jul 4, 2012
    Posts:
    745
  14. dumpling

    dumpling

    Joined:
    Apr 3, 2014
    Posts:
    2
  15. Nition

    Nition

    Joined:
    Jul 4, 2012
    Posts:
    745
    Thanks for that, Dumpling. Nice explanation of why this happens in the first link, and a fix (somewhat hacky, bit still) in the second one!
     
unityunity