Search Unity

  1. Get the latest news, tutorials and offers directly to your inbox with our newsletters. Sign up now.
    Dismiss Notice

Bolt project upgrade to visual scripting project

Discussion in 'Visual Scripting' started by ShallotGames, Mar 17, 2021.

  1. ShallotGames

    ShallotGames

    Joined:
    Feb 4, 2015
    Posts:
    5
    Hello everyone! My current project is developed with bolt 1.4.13, I would like to know if the old bolt project will be compatible with the new visual scripting version after unity2021 is released?
     
  2. ericb_unity

    ericb_unity

    Unity Technologies

    Joined:
    Nov 24, 2017
    Posts:
    65
    Yes it will, but you should wait for Visual scripting 1.6 to get the automatic upgrade from 1.43 asset store to built in version.
     
    ShallotGames likes this.
  3. ShallotGames

    ShallotGames

    Joined:
    Feb 4, 2015
    Posts:
    5
    That sounds greate!
     
  4. jrDev

    jrDev

    Joined:
    Nov 5, 2008
    Posts:
    1,745
    Hmm,

    This is not the case, my project broke with a ton of errors after import...

    Thanks,
    jrDev
     
  5. theor-unity

    theor-unity

    Unity Technologies

    Joined:
    Feb 26, 2016
    Posts:
    171
    which version ?
     
  6. jrDev

    jrDev

    Joined:
    Nov 5, 2008
    Posts:
    1,745
    I went from 2020 to 2021 Unity.

    Thanks,
    jrDev
     
  7. theor-unity

    theor-unity

    Unity Technologies

    Joined:
    Feb 26, 2016
    Posts:
    171
    sorry, I wasn't clear. could you give me:
    - the exact versions of unity (eg. 2021.1b1)
    - the bolt version you're using (1.4.13 ?)
    - the unity visual scripting version present in the 2021 build (1.5.0-pre or 1.6.0-pre)
     
  8. jrDev

    jrDev

    Joined:
    Nov 5, 2008
    Posts:
    1,745
    I am using 2021.1.0f1.
    VS 1.5.2
    Bolt 1.4.3

    The initial errors seemed to have been linked to Bolt Addon, so when I removed that the errors disappeared.
    But now I only have this in my inspector:
    upload_2021-3-26_14-1-7.png

    With no way to open them. Is there no upgrade steps?

    Thanks,
    jrDev
     
  9. ericb_unity

    ericb_unity

    Unity Technologies

    Joined:
    Nov 24, 2017
    Posts:
    65
    VS 1.5.2 don't have the automatic upgrade path in it. you will need to use 1.6.0-pre3 to get it to work. You will also need to get the Bolt Addons that is compatible with unity visual scripting, you will need to switch to this version. https://github.com/RealityStop/Bolt.Addons.Community#UVSsupport. I don't know if it is working with unity visual scripting.
     
  10. jrDev

    jrDev

    Joined:
    Nov 5, 2008
    Posts:
    1,745
    I will try this!

    Thanks,
    jrDev
     
  11. jrDev

    jrDev

    Joined:
    Nov 5, 2008
    Posts:
    1,745
    Hey @ericb_unity,

    Besides a few errors and warnings that showed when I upgraded which were clearable, it looks to have worked!

    Though I do get these warnings when I am in Play mode: "Could not load connection between 'xmin' of 'GraphInput#feee7...' and '%min' of 'InvokeMember#4ec8a...'.". Don't know what they mean. I have been making posts on the prerelease Discord channel on these!

    Thanks,
    jrDev
     
  12. ericb_unity

    ericb_unity

    Unity Technologies

    Joined:
    Nov 24, 2017
    Posts:
    65
    It kinda look like warnings from random nodes that got updated in the api. Normally you should be able to double click on the warning and it should open the graph with the problem. The node will show in yellow.
     
    jrDev likes this.
unityunity