Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We’re making changes to the Unity Runtime Fee pricing policy that we announced on September 12th. Access our latest thread for more information!
    Dismiss Notice
  3. Dismiss Notice

Bug Blank Unity Hub 3.1.1 launch error when creating new project

Discussion in 'Unity Hub' started by ExperKiller, Apr 14, 2022.

  1. ExperKiller


    Feb 10, 2021
    I updated unity hub to v3.1.1 and now a blank unity launch error message shows up everytime I try to open or create any project, just an error window with nothing inside it. I'm trying to use Unity editor 2021.3.0f1 LTS.

    Upon looking it up I've tried: Installing an older version of unity editor (2020.3.33f1 LTS), run unity hub as administrator, NOT running unity hub as administrator, change project locations, rebooting PC, full uninstall and reinstall of both the hub and the editor, creating a project using all of the premade templates unity offers, and downloading a different downgrade version of the unity hub (2.0) and trying all of the above with that. None of these solutions worked.

    I'm surprised from looking it up that there are very few solutions out there, and more so that none of them are working for me.

    The only thing I could accomplish was opening the unity editor via opening an already existing project's scene file, but the thing is I want to create a new project, and that I cannot do.

    Hope someone here can help me, thanks.
    Turtle-kun likes this.
  2. DUpsdell


    Sep 15, 2022

    I seem to be having the same issue I think. I could open projects if I uninstall unity hub and attempt to launch them directly via the editor, but if I have hub installed and try to launch anything, I'll always get the blank error with no information inside it.

    Did you ever find a solution to this issue?