Search Unity

  1. Unity 6 Preview is now available. To find out what's new, have a look at our Unity 6 Preview blog post.
    Dismiss Notice
  2. Unity is excited to announce that we will be collaborating with TheXPlace for a summer game jam from June 13 - June 19. Learn more.
    Dismiss Notice

Question Black Screen when making and loading projects on Linux

Discussion in 'Linux' started by Mallaboro, Nov 27, 2023.

  1. Mallaboro

    Mallaboro

    Joined:
    Sep 22, 2017
    Posts:
    19
    Swapped to Linux recently, been on-and-off trying to get it to run for a while now, figured I'd reach out for help. When I launch the application it's entirely black. Other users have reported this in the past and some of them have been able to resolve this issue, however what has worked for them hasn't worked for me.

    Operating System Linux-x86_64
    Arch (btw) version 2023.09.18-1
    Kernal version 6.5.8-arch1-1

    NVIDIA Driver Version 535.113.01
    NVML Version 12.535.113.01
    OpenGL version 4.6.0 NVIDIA 535.113.01

    xdg-user-dirs 0.18-1 (latest)

    Unity Hub 3.6.1 (Latest)
    Unity Game Engine 2021.1.21f1 (not latest)
    Partition (that stores hub & engine) filetype ext4

    dotnet-runtime 7.0.13.sdk113-1 (latest)
    dotnet-sdk 7.0.13.sdk113-1 (latest)
    mono-msbuild 16.10.1 (latest)
    mono-msbuild-sdkresolver 16.10.1 (latest)
    mono 6.12.0.205-1 (latest)
    visual-studio-code-bin 1.84.2-1 (latest)
    Error Logs

    Documents/Github/Roguelike/Roguelike-master/Roguelike/Logs/shadercompiler-UnityShaderCompiler0.log.
    No Player.log file has been generated.

    Code (CSharp):
    1. Base path: '/home/Far_Stranger5755/Unity/Hub/Editor/2021.1.21f1/Editor/Data', plugins path '/home/Far_Stranger5755/Unity/Hub/Editor/2021.1.21f1/Editor/Data/PlaybackEngines'
    2. Cmd: initializeCompiler
    3.  
    4. Unhandled exception: Protocol error - failed to read magic number (error -2147483644, transferred 0/4)
    5.  
    6. Quitting shader compiler process
    Other things I have
    • Visual Studio Code C# extension is installed
    Things I've tried
    • Resetting the UI Layout (this crashes the application)
    • Running the editor with the command flag -force-gfx-direct, this only launched the HUB, despite running the editor executable
    • Disabling Sync to VBlank in NVIDIA settings
    Things I've not yet tried
    • Running Unity Game Engine through Wine
     
  2. ChiwTheNeko

    ChiwTheNeko

    Joined:
    Mar 24, 2022
    Posts:
    140
    Which desktop environment are you using? X11 or Wayland?
    Did you try starting Unity with -force-vulkan?