Search Unity

Black Screen Upon Game-Launch

Discussion in 'Editor & General Support' started by Usernameisapain, Jul 14, 2019 at 3:13 PM.

  1. Usernameisapain

    Usernameisapain

    Joined:
    Sunday
    Posts:
    1
    Alright it is my first time posting on the Unity forums, so my apologies if I am posting it at the wrong forum, if so please do redirect me.

    1 - Issue
    2 - Attempts to fix said issue
    3 - Output log

    1 - The game is made by Chinese developers that aren't particularly active in patching or responding to players, hence why I am resorting to the Unity forums.

    The game itself launches normally, I can change the settings and start the character creation section. Afterwards when attempting to actually begin the game I face a black screen. However on fullscreen mode I will see 2 seconds of game-play with sound, I can even pause during this period, however shortly afterwards the screen turns black and only the mouse cursor is showing, the sound is gone as well. Sometimes the background music returns after a while, however the sound from activating the ui or moving the character are not there.

    2 - First I verified and reinstalled the gamefiles, with no effect. Did the classics such as updating my drivers and so on.

    I searched through the Chinese forums, to find that this issue exists there to, one of their solutions was to change the filename of two of the videofiles that play right after character creation and after finishing the game. This did not make a difference to me, it simply skipped the file, but the issue remained.

    Then I read about the issue being about the scaling, and running with GPU scaling, so I attempted to change these options and launching as such. With no effect. Similarly I fiddled with the compatibility option and the DPI, with no effect. Tried combinations of the scaling and the compatibility, as well as resolution and windowed/fullscreen.

    I also made a clean DDU uninstall/install of my driver. Updated my windows and other drivers, ran an image check and SFC scannow and chkdsk, with no result.

    Then I read that installing the Unity editor for the version used with the game could help(how so I don't know) but I tried it nonetheless, and still with no effect, tried with a newer version as well, but with no effect.

    3 - The output log file appears to be too large, so I'll just post some of the errors, and add the output log as a separate file. The line errors that I am getting are 51/ 57/ 437/ 1758/ 3124/ 3075


    nitialize engine version: 2017.3.1f1 (fc1d3344e6ea)
    GfxDevice: creating device client; threaded=1
    Direct3D:
    Version: Direct3D 11.0 [level 11.0]
    Renderer: AMD Radeon HD 7640G (ID=0x9903)
    Vendor: ATI
    VRAM: 1483 MB
    Driver: 15.301.1901.0
    Begin MonoManager ReloadAssembly
    - Completed reload, in 2.559 seconds
    Shader 'CalmWater/Calm Water [DX11]': fallback shader 'CalmWater/Calm Water [Single Sided]' not found
    <RI> Initializing input.

    <RI> Input initialized.

    <RI> Initialized touch support.

    The referenced script on this Behaviour (Game Object '! AmsMultiSceneSetup') is missing!

    Filename: Line: 1758)

    The referenced script on this Behaviour (Game Object '! AmsMultiSceneSetup') is missing!

    (Filename: Line: 1758)

    Setting up 2 worker threads for Enlighten.
    UnloadTime: 5.479188 ms
    Thread -> id: 1370 -> priority: 1
    Thread -> id: 16c0 -> priority: 1
    355V4C/356V4C/3445VC/3545VC (SAMSUNG ELECTRONICS CO., LTD.)
    USERNAMEISAPAIN
    Desktop
    b49ba33859d6bbb90046d212ea7427c3afec05dc
    39171
    AMD Radeon HD 7640G
    ATI
    4098
    Direct3D 11.0 [level 11.0]
    GraphicsMemorySize = 1483
    GraphicsShaderLevel = 50
    MaxTextureSize = 16384
    NpotSupport = Full
    OperatingSystem = Windows 10 (10.0.0) 64bit
    ProcessorCount = 4
    ProcessorType = AMD A8-4500M APU with Radeon(tm) HD Graphics
    SystemMemorySize = 7643

    (Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

    [FastOutputNodeConvert.cs][Parse][304] Null

    (Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)


    (Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

    [ResourceManager.cs][LoadBytes][136] Can't find bytes data Config/SkillTree/Skill/SkillTree070_001.txt

    (Filename: Line: 1758)

    The referenced script on this Behaviour (Game Object '') is missing!

    (Filename: C:\buildslave\unity\build\artifacts/generated/common/runtime/DebugBindings.gen.cpp Line: 51)

    [NavMeshLink.cs][CreateTile][267] Can't load navmesh Resources_Art/NavMesh/Nav_x11_z-12.asset

    (Filename: Line: 3124)

    Screen position out of view frustum (screen pos 640.000000, 0.000000, 29189.523438) (Camera rect 0 0 640 480)

    (Filename: Line: 3075)

    Screen position out of view frustum (screen pos 0.000000, 0.000000, 4000.000000) (Camera rect 0 0 160 120)

    (Filename: Line: 57)

    CollisionMeshData couldn't be created because the mesh has been marked as non-accessible. Mesh asset path "" Mesh name "shed_06_obj"

    (Filename: Line: 437)

    The AssetBundle 'event_box' can't be loaded because another AssetBundle with the same files is already loaded.
     

    Attached Files:

    Last edited: Jul 14, 2019 at 6:25 PM