Search Unity

  1. Unity 2019.4 has been released.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice
  3. Ever participated in one our Game Jams? Want pointers on your project? Our Evangelists will be available on Friday to give feedback. Come share your games with us!
    Dismiss Notice

Black Screen-Unity AR Camera not Working

Discussion in 'Handheld AR' started by jrd299, Jun 5, 2020.

  1. jrd299

    jrd299

    Joined:
    Feb 9, 2020
    Posts:
    1
    Hi everyone,

    I am new to Unity and I was following a tutorial online: Getting Started with ARFoundation in Unity on Youtube. I am using Unity 2019.3.9.f1 and have downloaded the following packages:

    AR Foundation

    ARCore XR Plugin

    ARKit XR Plugin

    I tried building and testing to an Android phone (Samsung Galaxy S4) but the screen just turned up black (this changed as I altered the color of the background on the AR camera). The unity logo popped up before it but there was no prompt to ask for camera permission. To test if this was just a phone problem, I downloaded an AR app from Playstore and that seemed to work. Multi-threaded Rendering is off, ARCore is switched to optional. I'm not sure what's wrong.

    Could you guys help me out? Thanks! Let me know if more info is needed.
     
  2. CindyG

    CindyG

    Joined:
    Mar 29, 2019
    Posts:
    1
    Have you enable ARCore in XR Setting?
     

    Attached Files:

  3. vedantgirkar32

    vedantgirkar32

    Joined:
    May 28, 2020
    Posts:
    4
    Even I'm facing the same problem. Yes I have enabled and tried the XRCore option. And now the option to grant the permission to enable the camera in android also doesn't pop up.
    I have tried with 2 different phones but nothing seems to work.
     
unityunity