Search Unity

Black screen after lauch (4.6.1)

Discussion in 'Android' started by Ikannuna, Dec 15, 2014.

  1. Ikannuna

    Ikannuna

    Joined:
    Oct 4, 2013
    Posts:
    9
    Hi there,

    I have run into a problem, and I am hoping someone can help me out.
    While creating an android game I decided to switch from 4.5 to 4.6.1.p1 The game ran good on 4.5. After the switch Unity said I needed to update the android sdk. I did this. I wanted to test the new apk on my device (a htc sensation, android 4.0.3) but it did not launch and keeps hanging on a black screen. I tested the apk on another device (samsung galaxy s4) and it worked fine.

    So what went wrong?
    I googled the problem, but I couldn't find anything that could help my or what I did not test (like yeah, I did add the scene to the build).
    I did test a total clean project with only a canvas and a button, but still a black screen (and so I do not suspect the project to be the problem)
    So I assume it should be some settings that changed? these are the current settings I use. However changing those in different ways did not change the result.
     
    Last edited: Dec 15, 2014
  2. Johnyc

    Johnyc

    Joined:
    Jan 22, 2014
    Posts:
    2
    Install 4.6.1p1 (patch#1) worked for me :)
     
  3. Ikannuna

    Ikannuna

    Joined:
    Oct 4, 2013
    Posts:
    9
    No. I am using that version. I have reinstalled it with the latest download to be sure. But no luck :(
    (edited main post for full version number)
     
  4. bitter

    bitter

    Unity Technologies

    Joined:
    Jan 11, 2012
    Posts:
    525
  5. Ikannuna

    Ikannuna

    Joined:
    Oct 4, 2013
    Posts:
    9
    Yeah! fixed.

    I thought the latest download was the patch. I thought wrong
    Many many thanks :)
     
  6. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    Next time read the forums and posts on the topic already.
     
  7. SamMcA

    SamMcA

    Joined:
    Dec 17, 2013
    Posts:
    8
    I'm getting this problem too, I've installed Install 4.6.1p1 on two different windows7 PCs and getting the same result. Works fine on android 4.4.x and 4.1.x but on all the 4.0.x devices I've tried I get a black screen (never gets to the Unity3D splashscreen).
     
  8. TimGS

    TimGS

    Joined:
    Apr 24, 2014
    Posts:
    63
    Same for me. Runs fine on 4.4 and 4.1 but black screen on 4.0 devices.
     
  9. SamMcA

    SamMcA

    Joined:
    Dec 17, 2013
    Posts:
    8
    Just installed patch 2 and it's working now.
     
  10. TimGS

    TimGS

    Joined:
    Apr 24, 2014
    Posts:
    63
    Oh, I didn't see patch 2 is out. Tried that and it fixed issue for me, too. =)
     
unityunity