Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. Join us on Dec 8, 2022, between 7 am & 7 pm EST, in the DOTS Dev Blitz Day 2022 - Q&A forum, Discord, and Unity3D Subreddit to learn more about DOTS directly from the Unity Developers.
    Dismiss Notice
  3. Have a look at our Games Focus blog post series which will show what Unity is doing for all game developers – now, next year, and in the future.
    Dismiss Notice

Billboard (View) particle effects rendered incorrectly in right eye [SteamVR]

Discussion in '5.4 Beta' started by mimminito, Jun 21, 2016.

  1. mimminito

    mimminito

    Joined:
    Feb 10, 2010
    Posts:
    780
    Hi,
    In b21 & b22 I am seeing an issue with the billboard particle effects (set to view mode). The issue is that the right eye is not rendering them correctly, but the left eye is. Here is a screenshot showing the issue.

    vr-particle-error.PNG

    This was not present in b20. I have filed a bug report for b21 and now b22 as well.
    Adam
     
  2. noorbeast

    noorbeast

    Joined:
    Jun 21, 2016
    Posts:
    9
    I am seeing a similar thing with particles in b21, yet it renders OK if I disable shadows for diffused lighting. Can you please check if that is the same for you.
     
  3. mimminito

    mimminito

    Joined:
    Feb 10, 2010
    Posts:
    780
    Are you disabling all shadows in Quality Settings or per light?
     
  4. richardkettlewell

    richardkettlewell

    Unity Technologies

    Joined:
    Sep 9, 2015
    Posts:
    2,071
    Can you post the bug number? Thanks
     
  5. mimminito

    mimminito

    Joined:
    Feb 10, 2010
    Posts:
    780
    @richardkettlewell Sure, its case 807558, and another one is 806157. I did two, one for b21 and one for b22.
     
    richardkettlewell likes this.
  6. noorbeast

    noorbeast

    Joined:
    Jun 21, 2016
    Posts:
    9
    Initially I just turned off shadows on the directional light.

    Once I figured out that shadows were the issue I switched to the Valve Renderer and disabled shadows globally, as the Valve render can then manage the shadows, so that is my current work around.
     
    mimminito likes this.
  7. mimminito

    mimminito

    Joined:
    Feb 10, 2010
    Posts:
    780
    I am going to continue using b20 as that is working for me. But I am hoping that when 5.4 ships it will be fixed.