Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. The 2023.1 beta is now available for testing. To find out what's new, have a look at our 2023.1 feature highlights.
    Dismiss Notice

Beta 5.3 - Editor Crashes when Prefab Dropped have a Material with "Hidden/InternalErrorShader"

Discussion in '5.3 Beta' started by angelodelvecchio, Oct 21, 2015.

  1. angelodelvecchio

    angelodelvecchio

    Joined:
    Nov 15, 2012
    Posts:
    170
    Beta 5.3 - Editor Crashes when Prefab Dropped have a Material with "Hidden/InternalErrorShader"

    If you delete a shader, or for any reason any prefab containing a material with "Hidden/InternalErrorShader", the editor crashes and close.

    *In the preview is possible to see the pink colored material.


    Computer

    AMD Athlon II X4 640
    8GB Ram
    Windows 7 64
    NVIDIA GEFORCE GTX 660
     
  2. angelodelvecchio

    angelodelvecchio

    Joined:
    Nov 15, 2012
    Posts:
    170
    ah ! and always in the console:

    IsFinite (m_CachedRange.first ) && IsFinite ( m_CachedRange.second )
     
  3. Alex-Lian

    Alex-Lian

    Guest

    Bug report # please?
     
  4. angelodelvecchio

    angelodelvecchio

    Joined:
    Nov 15, 2012
    Posts:
    170
    sorry Alex, i dont know how to help. It dont crashes the editor, just logs out in red saying that in debug.

    I will try to find if is about an animation, or asset, or whatever. Though, everything works good besides this, i just dont understand the persistence of this log.

    Thanks for attention

    if you are saying about this:
    "Beta 5.3 - Editor Crashes when Prefab Dropped have a Material with "Hidden/InternalErrorShader"

    If you delete a shader, or for any reason any prefab containing a material with "Hidden/InternalErrorShader", the editor crashes and close.

    *In the preview is possible to see the pink colored material.


    Computer

    AMD Athlon II X4 640
    8GB Ram
    Windows 7 64
    NVIDIA GEFORCE GTX 660"

    this is not happening anymore in beta 6.

    Thanks again.