Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Question Basic unit size and shadows

Discussion in 'General Graphics' started by engage88, Nov 21, 2023.

  1. engage88

    engage88

    Joined:
    Nov 21, 2023
    Posts:
    2
    I understand that Unity's default unit size is meters. But for some reason I want the default unit size to be in centimeters.

    There are no problems with modeling, animation, and particles because I can use centimeters as the standard.
    But there's a problem. If I change the scale of the object's size in centimeters, when I zoom in on it with the camera, the shadow becomes invisible.

    For example, if I set the scale of the basic 3D cube to 1, the shadow is visible from the camera, but if I set the scale of the cube to 100 or 1000 and zoom out so that it is all visible to the camera, the shadow is not visible.
    Is there any solution?
     

    Attached Files:

  2. kdgalla

    kdgalla

    Joined:
    Mar 15, 2013
    Posts:
    4,571
  3. engage88

    engage88

    Joined:
    Nov 21, 2023
    Posts:
    2

    I tried modifying the shadow distance and all other shadow-related options, but it had no effect. :(
     
  4. kdgalla

    kdgalla

    Joined:
    Mar 15, 2013
    Posts:
    4,571
    Also, If you have any baked lighting, you'll need re-gen or delete it and switch to real-time.

    I can't think of anything else, unless you've accidentally disabled shadow casting on your light or mesh renderer.