Search Unity

  1. How can our website serve you better? Give us your feedback. Take our survey and let us know.
    Dismiss Notice

Baking light problem from always

Discussion in 'Global Illumination' started by kqmdjc8, Aug 4, 2020.

  1. kqmdjc8

    kqmdjc8

    Joined:
    Jan 3, 2019
    Posts:
    102
    Hello there. I have never been able to bake the lights in Unity without artifacts. I have a scene made up from low-poly assets from kenney assets. All the settings are default. I have only changed:
    1) Lightmap Size to 2k and then to 4k - no result
    2) Compress Lightmaps on to off - no result

    Models have Generate Lightmap UVs checked to true.
    There is 1 directional light on the scene. Here are some of the artifacts:


    Questions now:
    1) how can I get rid of this? I think the geometry on this scene is really simple
    2) is it normal that it takes about 40 minutes to bake this simple scene? (Ryzen 5 3600)
     
  2. Vefery

    Vefery

    Joined:
    Feb 23, 2018
    Posts:
    101
    I suggest you to try to mess with Generate Lightmap UV settings, try to increase padding (in both lightmap and generate UV settings), check overlapping UVs after baking (choose this view in the panel with shaded, wireframed, etc views). You should also show us your lightmap settings. Also if artefacts appear on stitches between objects, you need to have quite high lightmap settings to make them invisible
    And yes, for some reason both Progressive CPU and Enlightened are extremely slow
     
    Pema-Malling likes this.
  3. Pema-Malling

    Pema-Malling

    Unity Technologies

    Joined:
    Jul 3, 2020
    Posts:
    98
    This is probably caused by an insufficient UV unwrap.
    If you are still having the issue, could you please post images of how the UV Overlap and Texel Validity views (https://docs.unity3d.com/Manual/GIVis.html), as well as of the lightmap lighting the object?
    A repro project would also help.
     
unityunity