Search Unity

  1. New Unity Live Help updates. Check them out here!

    Dismiss Notice

Bakery - GPU Lightmapper (v1.71) + RTPreview [RELEASED]

Discussion in 'Assets and Asset Store' started by guycalledfrank, Jun 14, 2018.

  1. guycalledfrank

    guycalledfrank

    Joined:
    May 13, 2013
    Posts:
    1,273
    It does it every time a model is imported. Bakery stores additional hints for the unwrapper in the meta file, and ftModelPostProcessor script applies them at the same time. I'm not sure at which point it went wrong in your project, as your github repo contained a different error (missing references, lightmaps aren't applied). If you can share any lightmaps-are-applied-but-uvs-are-wrong scene, I can investigate it.

    Try using "Dominant direction" mode. "Baked normal maps" won't give you enough detail in this case.

    I'm not sure, probably not. I can debug any problematic mesh if you can send it.

    That is surely possible, but I guess I'll leave it for now, it's been too long since the last release :) Will continue working on HDRP integration after that.
    One thing that bothers me is that HDRP is still in preview and it's ever-evolving. Investing time in preview features may be a waste of time if they suddenly redesign some system later (and they are doing it all the time). But if it'll become obvious some features are set in stone and their interface is final, I'll spend more time on that.

    Sorry, I'm not sure I understand what you say. Maybe post some screenshots?

    Driver crash. Probably execution took too much and TDR kicked it. You can try disabling it, but I would not. Instead, I recommend following the same guidelines as with any "out of mem" problems: https://forum.unity.com/threads/bakery-gpu-lightmapper-v1-55-released.536008/page-59#post-4579486

    Basically try lowering texels per unit and skylight/GI sample counts.
     
  2. the_mr_matt

    the_mr_matt

    Joined:
    Jul 21, 2015
    Posts:
    66
    That's a little bit tricky. The project is pretty large and I don't feel comfortable opening up the git repository. Is there anything in particular I can send to you or would you really need access to the whole scene? I suppose I could duplicate the project and strip out everything unnecessary.
     
  3. tgb1592006

    tgb1592006

    Joined:
    Jan 12, 2015
    Posts:
    7
     

    Attached Files:

    • 01.png
      01.png
      File size:
      3.6 KB
      Views:
      314
    • 02.png
      02.png
      File size:
      948 KB
      Views:
      399
    • 03.png
      03.png
      File size:
      18.8 KB
      Views:
      290
    • 04.png
      04.png
      File size:
      1 MB
      Views:
      312
    • 05.png
      05.png
      File size:
      13.6 KB
      Views:
      289
  4. tgb1592006

    tgb1592006

    Joined:
    Jan 12, 2015
    Posts:
    7
    This is a Frame Debug Pic!!!! there look like load first Scene lightmaps!!!!!
     

    Attached Files:

    • 06.png
      06.png
      File size:
      434.3 KB
      Views:
      297
  5. richterk

    richterk

    Joined:
    Nov 14, 2016
    Posts:
    1
    Doesn't work. "Failed to export scene" with a null pointer exception in a Giant block of code surrounded by a try block. Impossible to see where the error is coming from. Doesn't matter what settings I choose. Also, when I first imported the asset, it immediately threw errors on the Lightmapper.Radiosity checks. Had to fix that, then this issue.
     
  6. BenWoodford

    BenWoodford

    Joined:
    Sep 29, 2013
    Posts:
    80
    Yeah makes sense! Looking forward to the next release, I may have some time this week to try out the stuff on GitHub
     
    guycalledfrank likes this.
  7. guycalledfrank

    guycalledfrank

    Joined:
    May 13, 2013
    Posts:
    1,273
    No, I don't mean sharing the whole project, more like a test scene you had, but with the related problem.

    "Lightmapper.Radiosity" is legacy Unity API. You don't fix it by hand, Unity automatically upgrades scripts if you click "Go ahead":

    upload_2019-5-28_15-8-48.png

    This is necessary to make Bakery work on all different Unity versions.

    Check if included example scenes work. Does you scene contain any odd procedural geometry (not just meshes/terrains)?

    OK, I never used bundles myself, but some people mentioned they got it working on the thread. Unfortunately I can't give much of advice. Maybe just write a script that would apply proper lightmaps. Maybe get a refund.
     
  8. tgb1592006

    tgb1592006

    Joined:
    Jan 12, 2015
    Posts:
    7
    But I don't know how to do that, there look like some scripts teleport error lightmap to materials,how i can find this scripts.
     
  9. tgb1592006

    tgb1592006

    Joined:
    Jan 12, 2015
    Posts:
    7
    upload_2019-5-28_21-27-52.png
    it's this code cause the lightmaps errors?
     
  10. tgb1592006

    tgb1592006

    Joined:
    Jan 12, 2015
    Posts:
    7
    upload_2019-5-28_21-41-50.png


    I commented this line of code.Then tested some scenes,It works fine.But I don't know if it will cause other bad results.
     
    guycalledfrank likes this.
  11. the_mr_matt

    the_mr_matt

    Joined:
    Jul 21, 2015
    Posts:
    66
    I found the solution! All I had to do was right click all the affected assets in the project window, and reimport.
     
    guycalledfrank likes this.
  12. Mandelboxed

    Mandelboxed

    Joined:
    Apr 17, 2015
    Posts:
    37
    Hi,

    I've been using Bakery for a while now and have generally been very happy with the results. In my latest project however, I am getting some very strange shadows.

    Trying to track down the cause has been difficult. It looks like several new GameObjects are added to the scene after I press "Render" and these new objects cast unexpected shadows.

    Hierarchy before pressing "Render"
    upload_2019-5-28_17-13-34.png

    Hierarchy after pressing "Render"
    upload_2019-5-28_17-14-1.png

    These objects are actually visible in the scene as rectangles without a material (screenshot below)

    upload_2019-5-28_17-21-39.png

    What is especially strange is that after this occurs once in our relatively complex scene, it occurs in all scenes afterwards including a new one that I created as a test that has nothing but a camera, directional light (with Bakery Direct Light) and a cube. If I restart Unity then the new scene has no problem (the complex one still does).

    The screenshot below is the result of baking lighting in a new scene *if I have already baked lighting in the complex scene*
    upload_2019-5-28_17-29-8.png



    Below is another screenshot of the exact same scene. The only difference is that I restarted Unity and hit "Render" before baking lighting in the complex scene
    upload_2019-5-28_17-29-25.png

    Any assistance would be very much appreciated.
     
    Last edited: May 29, 2019
  13. guycalledfrank

    guycalledfrank

    Joined:
    May 13, 2013
    Posts:
    1,273
    I think the problem here is that asset bundles can't contain scripted components? And Bakery stores lightmap/renderer links in a script component that probably is never loaded via bundle.

    Interesting, I wouldn't expect that.

    Well I did suggest it previously :)

    Bakery can temporarily create these when exporting Area lights, but they should be placed where the lights are. Do you have any of these? Perhaps they have a deep nested rotation/scaling transformation? :confused:
    Such objects should never be left after the bake is done/scene unloaded though. And they definitely shouldn't appear in a new scene, so that's weird. Do you use Render Selected Groups anywhere?
     
  14. the_mr_matt

    the_mr_matt

    Joined:
    Jul 21, 2015
    Posts:
    66
    Oh my gosh thats embarrassing. Well I do apologize for wasting your time!
     
    guycalledfrank likes this.
  15. Mandelboxed

    Mandelboxed

    Joined:
    Apr 17, 2015
    Posts:
    37
    Just to clarify, the objects did not remain after the bake was done and were only visible before the scene was unloaded for baking. To take the screenshot I unchecked "Unload scenes before render". The objects did however seem to remain in memory somewhere as they affected subsequent bakes even in completely different scenes.

    You were absolutely right about the area lights and nesting. Moving area lights out of prefabs solved the problem. Thanks!
     
    guycalledfrank likes this.
  16. guycalledfrank

    guycalledfrank

    Joined:
    May 13, 2013
    Posts:
    1,273
    Oh well that's more like a bug I need to fix. Thanks for reporting!
     
  17. Loards

    Loards

    Joined:
    May 2, 2013
    Posts:
    105
    Hi! today i was working normally, and suddenly i started having these error and the Bakery menu was gone.


    Assets\Editor\x64\Bakery\scripts\ftRenderLightmap.cs(1957,55): error CS0619: 'LightmapEditorSettings.Lightmapper.Radiosity' is obsolete: 'Use Lightmapper.Enlighten instead. (UnityUpgradable) -> UnityEditor.LightmapEditorSettings/Lightmapper.Enlighten'


    Assets\Editor\x64\Bakery\scripts\ftRenderLightmap.cs(1961,58): error CS0619: 'LightmapEditorSettings.Lightmapper.PathTracer' is obsolete: 'Use Lightmapper.ProgressiveCPU instead. (UnityUpgradable) -> UnityEditor.LightmapEditorSettings/Lightmapper.ProgressiveCPU'

    Assets\Editor\x64\Bakery\scripts\ftRenderLightmap.cs(3281,55): error CS0619: 'LightmapEditorSettings.Lightmapper.Radiosity' is obsolete: 'Use Lightmapper.Enlighten instead. (UnityUpgradable) -> UnityEditor.LightmapEditorSettings/Lightmapper.Enlighten'


    There are not changes in the project or new plugins, it was just from one moment to other.

    i already re imported bakery but there is no change.

    Thanks!


    EDIT: I did the changes stated in the error and now is working again, i have no idea what happened.
     
    Last edited: May 29, 2019
  18. guycalledfrank

    guycalledfrank

    Joined:
    May 13, 2013
    Posts:
    1,273
    liudian208, Akshara and Dawie3565 like this.
  19. Tudor

    Tudor

    Joined:
    Sep 27, 2012
    Posts:
    125
    Frank, could you update the documentation to clarify this point? Because I spent a long time trying to figure out: how do I render a lightmap group with a higher texels per unit count? And the answer is: you can't? I guess I manually have to split my LMG into 2 or 4 LMGs.. My RTX Quadro videocard runs out of its 5GB of memory when I set the lightmap group to 8k so I can't use that. [Edit] It seems it does not crash with 8k LMG when I set the render tile size to 1k (not 2k or 4k), and the atlassing Max Resolution to 2k instead of 4k (for some reason).

    Can you also please explain what is the overhead in rendering multiple light groups (not at once) versus rendering the whole scene once. I assume there's a lot of intersection of effort since there is contribution from other groups to the group you are currently rendering. But rendering e.g. a scene split into 4 lightmap groups should still be faster than rendering the whole scene 4 times, right?
     
    Last edited: May 30, 2019
  20. Loards

    Loards

    Joined:
    May 2, 2013
    Posts:
    105

    Awesome thank you!

    Also, when we can expect the V 1.6?

    EDIT: i Just found out that the "Use scene named output path" is not working, the light maps are stored in the manual output path even when you activate the other option.

    EDIT 2: The "split by scene" also is not working, all the scene are sharing the same atlases in the same folder.
     
    Last edited: May 31, 2019
    guycalledfrank likes this.
  21. ivabibliocad

    ivabibliocad

    Joined:
    Jan 11, 2014
    Posts:
    71
    Hello,
    I just placed the script in the prefab, placed the bakery lights, baked the thing suing the prefab component directly in the prefab, and then click "save current render settings to prefab".. but always fail when dropping it to another scene. It never holds the lightmap information... I guess this is common occurrence with an easy fix???
     

    Attached Files:

  22. tremault

    tremault

    Joined:
    Oct 16, 2015
    Posts:
    50
    Hi, I just did a build for the first time and i came across something strange. in every scene where i have balked lighting with bakery, my autofences disappear. there seems to be something causing an incompatibility. there is no problem in editor, it is only when i play in build build.
    the shaders on the autofences are normal. there are some scripts on them that do something, I know not what. I realise the contents of those scripts are not your responsibility, but if I wanted to check what would you imagine I would need to look for? I will also talk to hte creator of autofence builder and see what they can suggest.
     
  23. guycalledfrank

    guycalledfrank

    Joined:
    May 13, 2013
    Posts:
    1,273
    Basically:
    - First we have object UV layouts with their size proportional to surface area.
    - Then we scale each layout by "Scale in lightmap"
    - Then we scale all layouts by the total area occupied by all objects in the atlas, multiplied by their current UV size. This has a normalizing effect, i.e. the bunch of UV layouts gets closer to 0-1 range.
    - Then we try to pack the layouts to a single square atlas
    - If they don't fit, we scale them down a bit and try again.
    - If they fit, but take only a small portion, we scale them up.

    Increase group resolution? The difference between "Pack atlas" groups and default automatic atlasing is that if automatic atlaser encounters a large object that doesn't fit in any existing atlas, it will create another (and so many lightmaps are generated); but "Pack atlas" will have to fit everything in one atlas, so it will place the large object inside, but scale other stuff down accordingly (as it is smaller in comparison).

    If you have lots of objects, and even a high resolution LMGroup does not give enough detail for everything, then yes.

    Yeah, be careful with numbers like that. Splitting to multiple 4k will use less memory.

    That would indeed reduce some memory footprint, but I'd still avoid 8k.

    The overhead is that for every LMGroup+Pass pair ("pass" being any intersecting light or GI bounce), lightmapper has to load the scene and the UV GBuffer (In fact, I had a batching system working that would omit reloading the scene, but for some reason it was unstable. Will still have to finish it some day). For complex scenes (even Sponza) rendering time itself takes much longer than the overhead though.
    LMGroups do not affect the geometry being traced, they only change where the rays originate. For direct lighting there isn't much difference in tracing from 4x512 textures or 1x1024. But for GI, Bakery has to load direct lighting or previous bounce for every LMGroup at once, in case the ray will hit them (to bounce/reflect the value). If GI VRAM optimization is enabled, it tries so be smarter: first it determines visibility between different LMGroups, then, before every bounce, it generates lightmap LODs and uses them. So, if two 4096-sized LMGroups are far apart, they won't "see" each other that well, so even a 64x64 LOD may suffice -> GI will only load one 4096 (self) + 64 (other).
    Sounds kinda complicated, but hopefully it clears something a bit.

    Soooon.
    It's done, but I need to run some tests.

    Really? That's like a very simple option and many people use it. Does it happen when you have many scenes open at the same time?

    "Split by scene" does not affect folders. It only changes how objects are distributed into atlases.

    Tried clicking "Apply" on the prefab?

    I'm not sure what is autofences. Is it this? Maybe they generate geometry at runtime? Maybe they use additionalVertexStreams? Try disabling batching and see if it does something.
     
    Tudor likes this.
  24. ivabibliocad

    ivabibliocad

    Joined:
    Jan 11, 2014
    Posts:
    71
    Where's that option I've search everywhere for that button and can't find it!
     
  25. ivabibliocad

    ivabibliocad

    Joined:
    Jan 11, 2014
    Posts:
    71
    I've found it.... first time using this option. For anyone else with the same problem just head to the button that says "overrides" on the top right corner and then choose the last option "apply all"... that's it!!
    Thanks Frank!
     
  26. ivabibliocad

    ivabibliocad

    Joined:
    Jan 11, 2014
    Posts:
    71
    Not so fast...... The bakery component says prefab "connection ok", nevertheless when I drag-drop that prefab from the folder is currently stored it comes with no lightbake. This happens on other scenes as well as the one I used just to bake the prefab? Now I'm really confused here. I'm pretty sure this is is as simple as the apply step, but at this point....not close for me...
     

    Attached Files:

  27. Loards

    Loards

    Joined:
    May 2, 2013
    Posts:
    105

    I know, i just found out that, i have 4 scenes loaded, lightmaps baking works fine, but they are saved into the manually named folder with or without the option active. I did several test and always happens.

    The split by scene also has the issue, im doing the lightmaps of the 4 scenes at the same time and all the atlases are stored into a single light map texture.

    Other thing that is happening and im not sure why, is that the parameters in the bakery window are being reset every time i open unity and need to set everything again, i dont know if this is unity fault or something weir with the plugin.

    It just came to my mind a new test, i will do it and update into that.

    EDIT: OK, i saw what is happening, even using the "use scene named path" option, uses the path that is in the field even when the option is active, even if this path is incorrect. the way to fix it is, disabling the option, clearing the field and then enabling again the option. Apparently when the option is active, you fill that filed with the path of the current scene the first time, but if you load a new scene, that field is not being reset, so it uses the old path and not the one of the new scene.

    The Split by scene option started working again, weird.
     
    Last edited: May 31, 2019
    guycalledfrank likes this.
  28. Loards

    Loards

    Joined:
    May 2, 2013
    Posts:
    105

    Ok, these changes actually made another problem, when i hit the "render reflection probes" button, starts the unity light mapper like pressing the "generate lighting" button in the lighting window, thus breaking the bakery light maps.
     
  29. tremault

    tremault

    Joined:
    Oct 16, 2015
    Posts:
    50
    Hi, yes it is that one.

    I wasn't sure what you meant by disabling batching. I decided to make a particular fence as 'non static' for batching, and when i built my project that fence was now visible. does this confirm a suspicion you had?
     
  30. ivabibliocad

    ivabibliocad

    Joined:
    Jan 11, 2014
    Posts:
    71
    I solved it... But I don't know if this is a common occurrence. To make the long story short, bakery only stores the lighmap information into prefab if the render mode is "indirect"... Hope it helps someone...
     
  31. guycalledfrank

    guycalledfrank

    Joined:
    May 13, 2013
    Posts:
    1,273
    Ah yes... seems like they buried it a bit deeper after the introduction of nested prefabs :) Older Unity versions had a plain "Apply" button.

    Did you bake after fixing the connection?

    Hmm that is not true. You probably did something else (like, baked after fixing the connection) and mistakenly attributed it to indirect (?)

    That should never happen and may be the source of your other problems. Do you save the scene after changing settings (even if you try closing it, Unity will ask about saving changes)? Do you have a different scene being active every time? Bakery settings are saved into scenes, so switching active scene will switch active settings.

    Ugh, I will check that, thanks.

    Reflection probe render is indeed just calling Unity's own probe baking function (it renders them with engine cameras anyway), but it should not start lightmap/lightprobe bake. Also did you try reopening the scene? Should get lightmaps back in place, Unity cannot clear Bakery LM storage.

    It does. Did you use vertex lightmapping BTW?
    Basically some features in Unity (like additionalVertexStreams) are incompatible with batching.
     
  32. Zoidberg656

    Zoidberg656

    Joined:
    Sep 26, 2018
    Posts:
    8
    How would I go about avoiding completely pitch black shadows? I have a cave system with a few lanterns, but deep in the caves it becomes pitch black. The skylight doesn't affect the cave shadows at all.
     
  33. tremault

    tremault

    Joined:
    Oct 16, 2015
    Posts:
    50
    i'm not sure how to do that, I haven't looked into it. i had a look now and i can't find an option for it. google suggests it's in shaders, but my shader doesn't use it.
    I think what I need to do now is liaise with the developer of auto fence builder and see if they can shed some light on it with the things you have told me.
     
    guycalledfrank likes this.
  34. guycalledfrank

    guycalledfrank

    Joined:
    May 13, 2013
    Posts:
    1,273
  35. tremault

    tremault

    Joined:
    Oct 16, 2015
    Posts:
    50
    Hi guycalledfrank,
    You may be interested that a compromise has been found for the issue with auto fence and wall builder.
    the details are here - https://forum.unity.com/threads/auto-fence-builder-released.274677/page-7#post-4605061
    in short, the AFWB will auto-combine fences when building a project. this combined fence is clearly incompatible. this can be circumvented by either disabling the 'combine' option on the fence objects or by creating a 'merged mesh copy'.
    Both these methods result in a fence that is compatible with Bakery.
     
    guycalledfrank likes this.
  36. Deusald

    Deusald

    Joined:
    Feb 11, 2014
    Posts:
    30
    @guycalledfrank
    I can't find the beta on github. Can you send me a link? Is the new version more close? :p
     
  37. guycalledfrank

    guycalledfrank

    Joined:
    May 13, 2013
    Posts:
    1,273
    Aha, interesting. I contacted the developer, maybe we can figure something out.

    Where are you looking? :)
    https://geom.io/bakery/wiki/index.php?title=Github_access
     
    tremault likes this.
  38. Tudor

    Tudor

    Joined:
    Sep 27, 2012
    Posts:
    125
    So about swapping or changing or blending between baked lightmaps at runtime:

    I'm also interested in this. Actually I thought it was already a feature. So you're saying that I have to, in edit mode, after the bake finishes, run an editor script that saves the contents of those 3 things? But do I have to go through all Renderers in the scene to save the Renderer.lightmapIndex and Renderer.lightmapScaleOffset and then reapply them later when I swap lightmaps?

    Also, How do you recommend handling reflection probes when you switch? I guess I would store 2 prebaked sets, or render them through script after the switch.

    What about if I want to smoothly blend between lightmaps, ie have a version of my room with lights dimmed and another with lights full on, and have a slider for "light intensity"? Shouldn't there be a really easy way to just blend or at least swap the lightmap texture references as a global shader parameter without bothering with the CPU side at all?
     
    Last edited: Jun 2, 2019
  39. the_mr_matt

    the_mr_matt

    Joined:
    Jul 21, 2015
    Posts:
    66
    What are some things I can do to optimize my scenes for baking without sacrificing too much quality i.e. reasonable resolution and texels? I have some fairly large levels with probably hundreds of trees. Would it be beneficial to combine several trees into one mesh?
     
  40. maxaud

    maxaud

    Joined:
    Feb 12, 2016
    Posts:
    162
    I'm getting the following errors (and 34 warnings not listed):

    Code (CSharp):
    1. Assets\Editor\x64\Bakery\scripts\ftRenderLightmap.cs(1957,55): error CS0619: 'LightmapEditorSettings.Lightmapper.Radiosity' is obsolete: 'Use Lightmapper.Enlighten instead. (UnityUpgradable) -> UnityEditor.LightmapEditorSettings/Lightmapper.Enlighten'
    2. Assets\Editor\x64\Bakery\scripts\ftRenderLightmap.cs(1961,58): error CS0619: 'LightmapEditorSettings.Lightmapper.PathTracer' is obsolete: 'Use Lightmapper.ProgressiveCPU instead. (UnityUpgradable) -> UnityEditor.LightmapEditorSettings/Lightmapper.ProgressiveCPU'
    3. Assets\Editor\x64\Bakery\scripts\ftRenderLightmap.cs(3281,55): error CS0619: 'LightmapEditorSettings.Lightmapper.Radiosity' is obsolete: 'Use Lightmapper.Enlighten instead. (UnityUpgradable) -> UnityEditor.LightmapEditorSettings/Lightmapper.Enlighten'
    4.  
    I've tried restarting Unity and tried reimporting but it says I already have the asset in my project.
    Using 2019.1.1f1 (Unity for PlayStation). No "Bakery" menu at the top either.

    Thank you.
     
  41. guycalledfrank

    guycalledfrank

    Joined:
    May 13, 2013
    Posts:
    1,273
    This feature is planned but not yet implemented.

    Exactly.

    Reflection probes are saved to regular texture assets. I think if you loop over ReflectionProbe components in your scene and check this property, it will point you to the texture. You can then get its asset path and make a copy of it somewhere, then later plug it back in.

    That's the compilcated part. You'll need a shader, and you can't do it with surface shaders (because they hide baked lighting from you). You'll need to manually read 2 textures and lerp between them. With Unlit (non-surface) shaders this is quite easy though.
    Another option is to modify the texture itself, but it's gonna be more expensive due to fillrate and lack of compression. You would need 2 original compressed textures and 1 RenderTexture. Draw a quad (Graphics.Blit) with a blending shader, use RenderTexture as lightmap. Although it would work with unmodified shaders, I'd avoid that, as filling a large HDR RenderTexture every frame + reading uncompressed lightmap does not worth it.
    My planned approach was to inject cheap blending code into Unity's CGIncludes.

    Swapping is not a problem. Just modify LightmapSettings.lightmaps entry and voila.

    Combining won't help baking speed. But here are some hints:
    - Try lowering skylight/GI samples and see if it works for you scene (but I wouldn't go lower than 8).
    - Try lowering GI bounces count and see if there's much impact (but I wouldn't go lower than 2). Number of GI bounces doesn't affect memory, only takes additional time.
    - Opacity maps can affect performance, especially if used on many large intersecting polygons. See if you can reduce the amount of transparent/cutout triangles or even omit them from baking.
    - If your trees are Mesh Renderers, check if you can use light probes for them instead of lightmaps. You can set Scale in Lightmap to 0 on the trees - they will still cast shadows/reflect light, but won't get lightmapped on their own. For trees that are "painted" using terrain editor this is done automatically (engine doesn't allow them to have lightmaps anyway).
    - If most of the trees are a backdrop, you can omit them from rendering and only bake the ones closest to player/camera. For example, closest trees can be Mesh Renderers, and distant trees are painted. You can then disable painted trees baking by settings exportTerrainTrees=false in ftBuildGraphics.cs (proper UI checkbox was added in v1.6 and coming soon).

    Read this: https://geom.io/bakery/wiki/index.p...2.80.9D_and_.E2.80.9CUnityUpgradable.E2.80.9D
     
    Tudor likes this.
  42. Tudor

    Tudor

    Joined:
    Sep 27, 2012
    Posts:
    125
    Just a heads-up @guycalledfrank , the Global Shader tweaks buttons seem to not work due to windows system file permissions:

    "UnauthorizedAccessException: Access to the path "Assets/Editor/x64/Bakery/shaderSrc/ftrace.cginc" or "C:\Program Files\Unity\Hub\Editor\2019.1.2f1\Editor\Data\Managed\UnityEngine/../../CGIncludes//ftrace.cginc" is denied."

    I know you said run unity as admin, but with the new unity hub crap, running as administrator doesn't seem to do it. Tried to run the hub as admin - I think it starts up a non-admin unity, and also tried to separately run unity itself as admin - but that also defaults to opening a kind of unity hub on its own, so still doesn't work. I wager it does work if you download unity via the custom downloads on their website, via their .torrent, because that version is (still) truly standalone and without any unity-hub dependencies.
     
  43. Tudor

    Tudor

    Joined:
    Sep 27, 2012
    Posts:
    125
    Just realized there is no support for shadows on transparency on objects. It's binary, full shadow (>0.5 alpha) or no shadow (<0.5 alpha).

    Is there a raisin why it's hard to do a simple ray contribution multiplier based on the alpha of the material the ray hits? Does the nvidia library you use not support splitting the ray in 2 if the object you hit is transparent? What about just dithering transparent objects? Like, use half the rays to bounce off and the other half to go through with a lower intensity.

    I guess I'll render the scene twice with and without transparent shadows, and blend the lightmaps by 50% in Photoshop... :p Better than nothing, for e.g. curtains.
     
  44. maxaud

    maxaud

    Joined:
    Feb 12, 2016
    Posts:
    162
  45. maxaud

    maxaud

    Joined:
    Feb 12, 2016
    Posts:
    162
    I go to "Assets > Run API Updater..." and nothing happens. Any suggestions? Should I go through each script manually?
     
  46. guycalledfrank

    guycalledfrank

    Joined:
    May 13, 2013
    Posts:
    1,273
    Weird. Will see what can be done about it. The problem is it doesn't happen to me (even if I run with regular user rights). Maybe has to do something with me using Win 7 (and you have 10 I guess?). Also never used the hub before.

    This is planned.

    Using simple semitransparent materials is not enough for curtains anyway, as they also scatter light in all directions. But... there are some options. Check these:
    https://twitter.com/guycalledfrank/status/1130070566759800832
    https://twitter.com/guycalledfrank/status/1130089572786946049

    You must be having unrelated (non-upgradable) script errors in your project preventing Unity updater from running:

    upload_2019-6-3_20-16-10.png
     
    Tudor likes this.
  47. Loards

    Loards

    Joined:
    May 2, 2013
    Posts:
    105

    You are aright, even when the LM breaks, reloading the scene fixes it, but i still cant render reflection Probes, the whole light maps process from unity starts, before only the reflection probes where baked and due the fact that im baking multiple big scenes, its impossible to wait the whole process only fro the reflection probes.
     
    Last edited: Jun 3, 2019
  48. guycalledfrank

    guycalledfrank

    Joined:
    May 13, 2013
    Posts:
    1,273
    Are you using Occlusion Probes checkbox? If not, the only thing Unity should do is to initialize a light probe asset in an empty (no geometry whatsoever) scene.
    If yes... don't, I guess. Unity does not support modifying occlusion probe data properly by third-party code, so my options here are limited.
     
  49. Tudor

    Tudor

    Joined:
    Sep 27, 2012
    Posts:
    125
    Ohohoh yeah, you can't not use the unity hub anymore.. unless you get the torrent version of unity. Also the hub doesn't work through VPNs or university wifis/proxies, and ofc it's a new system tray process that runs all the time lol It's so great. Yes I'm using windows 10 (at work).

    (I will be so excited when the new BSF Banshee engine comes out :p https://github.com/GameFoundry/bsf/blob/master/Documentation/GitHub/features.md no bullshit, correct architecture, open source)
     
    guycalledfrank likes this.
  50. Loards

    Loards

    Joined:
    May 2, 2013
    Posts:
    105
    No, im no using Occlusion probes, im using the full lighting option and setting the basics only. Im attaching a GIF so you can see what its going on.

    The part when everything turn yellowish, actually happens and its not a gif compression error.

    Note: im not letting the LM to finish on the gif, but you can see that the unity LM process begins.

    Probably there is a change in unity 2019 that its making the whole LM process to begin instead of only the Reflection Probes, the weird thing is, that we been working with this version since almost a month and suddenly this happened.
     
unityunity