Search Unity

  1. Looking for a job or to hire someone for a project? Check out the re-opened job forums.
    Dismiss Notice
  2. Good news ✨ We have more Unite Now videos available for you to watch on-demand! Come check them out and ask our experts any questions!
    Dismiss Notice

Baked light jagged shadows

Discussion in 'Getting Started' started by plufz, Jun 2, 2020.

  1. plufz

    plufz

    Joined:
    May 26, 2020
    Posts:
    9
    Hi!

    I'm trying out Unity for the first time. Just trying to setup a really simple low poly scene with an island. But I can't for my life get the shadows to render correctly when I'm trying to bake the light.

    It renders correctly on some objects but not others, especially my island object (created in blender). I wonder if something is wrong with my uv maybe? I made a seam at the waist of the island so it is split into two round uv:s. Is that not an okay uv? If I increase the lightmap resolution by a lot it gets better but it is still jagged (and I get reeeally long render times for just these very simple objects, so it will be really hard to use those settings on a full scene).

    I've tried to google this but havent found anything that works yet. I have seen that other people had trouble with jagged shadows before with the previous lightmapper "Enlighten" but I'm using "Progressive CPU".

    Any ideas at all are very welcome.

    The scene:
    https://www.dropbox.com/s/0t1xi1jklajietm/Screenshot 2020-06-02 11.41.29.png?dl=0

    The island UV:
    https://www.dropbox.com/s/ok8pko52cm8nlgi/Screenshot 2020-06-02 11.42.11.png?dl=0
     
  2. plufz

    plufz

    Joined:
    May 26, 2020
    Posts:
    9
    I now figured it out. I had just a very strong directional light to light the scene since my blender model was very dark. That was the cause of all problems. Using lighter textures and a lighter environment light worked a lot better.
     
unityunity