Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.
  2. We’re making changes to the Unity Runtime Fee pricing policy that we announced on September 12th. Access our latest thread for more information!
    Dismiss Notice
  3. Dismiss Notice

Bad State when Mixed Reality Headset Unplugged

Discussion in 'VR' started by Barkers-Crest, Oct 23, 2018.

  1. Barkers-Crest


    Jun 19, 2013
    (Case 1093505)

    In player settings I am checking Virtual Reality Supported.

    I add Windows Mixed Reality and None as supported Virtual Reality SDKs.


    When the headset is plugged in when starting the game everything works fine in Mixed Reality.

    When starting the game with no headset plugged in the game renders a single, solid color and is unresponsive to input. In addition to that you have to press windows key and kill the game from the taskbar otherwise your computer is taken over full screen by the game and you are unable to switch to any other applications.

    What I would expect to happen, and this is how it worked on earlier versions of 2017, is the game would recognize XR is not available and start in 2D non-vr mode.
  2. ivan20071


    Nov 15, 2017
    Currently, in my application, to solve this problem I run the HolographicSpace.IsAvailable test in the App class.
    In case the property is false I go out immediately from the application (the best thing is to display at least one toast notification).
    The property test done in the App class constructor seems to cause a crash on some PCs. I recently moved the test into the Run function and it seems that the crashes no longer occur.
    Code (CSharp):
    1.         public void Run()
    2.         {
    3.             if (HolographicSpace.IsAvailable)
    4.             {
    5.                 m_AppCallbacks.Run();
    6.             }
    7.         }
  3. Barkers-Crest


    Jun 19, 2013
    Unfortunately for our situation we need the game to run in 2D mode. I did get a response to the bug report.

    It was marked as a duplicate for the following bug:

    The QA staff noted this bug is fixed in 2018.3 beta (it is I checked) but not in 2018.2 (which we are in). The QA staff member requested a backport for 2018.2.