Search Unity

Back of 3d model not rendering

Discussion in 'General Graphics' started by HudsonL, Jun 20, 2021.

  1. HudsonL

    HudsonL

    Joined:
    Apr 30, 2020
    Posts:
    6
    I imported a 3d model from blender but from the backside its invisible. Does anyone know how to fix this i really need to
     

    Attached Files:

  2. Mauri

    Mauri

    Joined:
    Dec 9, 2010
    Posts:
    2,343
    What's happening there is so-called
    back-face culling
    . By default, only geometry that is facing the camera is rendered - meaning: every object has just one side.

    In custom shaders, you can turn off back-face culling by putting
    Cull Off
    into the
    SubShader
    section. However, this will make the other side lit incorrectly and thus messing up lighting. Not ideal...

    The easiest and better way would be to duplicate the geometry and flip the normals in Blender.
     
    richardkettlewell likes this.
  3. HudsonL

    HudsonL

    Joined:
    Apr 30, 2020
    Posts:
    6
    THANK YOU SO MUCH YOU JUST SAVED MY GAME!!!
     
    Mauri likes this.
unityunity