Search Unity

  1. Unity support for visionOS is now available. Learn more in our blog post.
    Dismiss Notice

Audio Not playing in Unity at all. [SOLVED]

Discussion in 'Audio & Video' started by tmanallen, Jul 3, 2016.

  1. Armegalo

    Armegalo

    Joined:
    May 14, 2018
    Posts:
    28
    Just off the top of ma head sounds like you've got too few audio channels available - go to EDIT > PROJECT SETTINGS > AUDIO and increase both max voices and max virtual voices
     
  2. bodhi_berry

    bodhi_berry

    Joined:
    Feb 13, 2017
    Posts:
    8
    I've got a strange audio bug going on that nothing in this thread so far has fixed.
    I'm developing a game with Oculus Quest, testing with Link. Using Unity 2019.4.7f1
    Yesterday, without any changes of my own, my audio stopped playing in the editor. No sound at all when I enter play mode... until I exit playmode - then I hear one loud click of the music that should have been playing the whole time.

    But if I put on my headset while in playmode, the correct sounds are playing the entire time.

    Looks like there was an Oculus update yesterday, could have something to do with it?

    Any ideas, friends?
     
    Verne33 likes this.
  3. SkizzleD

    SkizzleD

    Joined:
    Jul 6, 2020
    Posts:
    6
    +1
    I'm having the exact same experience with my Oculus Quest build.
     
    Verne33 and bodhi_berry like this.
  4. steveo98501

    steveo98501

    Joined:
    Dec 27, 2020
    Posts:
    2
    That was what fixed it for me
     
    thorolfyggsson and edeena121 like this.
  5. buituht

    buituht

    Joined:
    Dec 6, 2020
    Posts:
    1
    thanks you.
     
  6. Leohd

    Leohd

    Joined:
    Feb 7, 2017
    Posts:
    32
    There should really be a giant message saying "Audio Muted" and a highlight on that editor button. It's not something people expect and may mistake the muted audio for some coding errors.
     
  7. Rachan

    Rachan

    Joined:
    Dec 3, 2012
    Posts:
    747
    Wow it fixed me too. I don't know why I check this button
     
  8. Paraave

    Paraave

    Joined:
    Sep 28, 2020
    Posts:
    2
     
    AlexanderTutyhin likes this.
  9. unity_Rish

    unity_Rish

    Joined:
    Apr 26, 2021
    Posts:
    1
    It still doesn't work, i have mute on both the source and the game view unchecked, applied all the audio settings, and i have an active audio listener, i am using the audiomanager script after following along with this tutorial
    ,
     
    KingOfDwarf likes this.
  10. Spider-Ahmed

    Spider-Ahmed

    Joined:
    May 20, 2021
    Posts:
    1
    man thank you ☻
     
  11. Urjin

    Urjin

    Joined:
    Mar 16, 2020
    Posts:
    5
    Don't let this topic get down )))
    5 years passed, and users still going to press "mute audio" (me too, of course).
    Thanks to all, switch this off helped
     
  12. NotNitish

    NotNitish

    Joined:
    May 12, 2021
    Posts:
    2
    Check if u mue=ted audio in game mode
     
  13. yengNami

    yengNami

    Joined:
    Feb 14, 2021
    Posts:
    14
    Unity should give an option for this buttons to be more visible when enabled or disabled.
     
  14. StevenTillson02

    StevenTillson02

    Joined:
    Jun 30, 2021
    Posts:
    11
    followed the same and my issue is fixed now.
     
  15. mhussar

    mhussar

    Joined:
    Feb 22, 2014
    Posts:
    15
    Wow, this was sooooooo frustrating. You guys are all great!!!!
     
  16. tomachinz

    tomachinz

    Joined:
    Mar 2, 2019
    Posts:
    15
    Check your console. You may have runtime code that crashes the audio system. In my case I see this error:
    PlayOneShot was called with a null AudioClip.
    UnityEngine.AudioSource:playOneShot (UnityEngine.AudioClip)
    Unity.FPS.Gameplay.PlayerCharacterController:Update () (at Assets/FPS/Scripts/Gameplay/PlayerCharacterController.cs:205)

    In my case switching from WebGL export target back to Linux desktop target made the sound come back. Mysterious.
     
  17. bambamharry

    bambamharry

    Joined:
    Jul 27, 2021
    Posts:
    4
    i did it already but its not working also i wen to project settings to check the audio
     
  18. Give_up

    Give_up

    Joined:
    Sep 28, 2021
    Posts:
    7
    I am fighting with this right now too
     
  19. YourMomUnited

    YourMomUnited

    Joined:
    Nov 2, 2021
    Posts:
    2
  20. WARW0LF

    WARW0LF

    Joined:
    Oct 1, 2016
    Posts:
    16
    I had a no audio issue and tried looking for solution, for me, for some reason the pitch on my audio sources were set to zero, setting it to 1, normal, fixed, it, not sure how or why this happened but hopefully it might help someone else
     
  21. hoangpro68

    hoangpro68

    Joined:
    Oct 20, 2021
    Posts:
    1
  22. ZeroPi

    ZeroPi

    Joined:
    Apr 6, 2021
    Posts:
    4
    Had the same issue. No audio at all. I restarted Unity and the audio played again :)
     
  23. AquaGhost

    AquaGhost

    Joined:
    Jan 27, 2013
    Posts:
    94
    Had this issue in 2021 and resetting audio settings in the Proj Settings fixed it. This was also freezing timeline preview (with the small play button) which I thought was unrelated.
     
  24. MBrown42

    MBrown42

    Joined:
    Jan 23, 2018
    Posts:
    86
    I finally traced my completely muted unity audio of any kind to the windows system volume mixer, which had a separate channel for any unity audio, and it was muted. unmuted, and sounds are back. I do record with the built in xbox game recorder, so beware if you do also it seems to mute the system volume channel in addition to the video recording volume.
     

    Attached Files:

    heartingNinja and Kromvel like this.
  25. inskino

    inskino

    Joined:
    May 25, 2022
    Posts:
    1

    thank you!! It solved i am so happy!!
     
  26. Verne33

    Verne33

    Joined:
    Apr 12, 2020
    Posts:
    32
    Did you ever find a solution to this?
     
  27. Lokesh2022

    Lokesh2022

    Joined:
    May 8, 2021
    Posts:
    9
    Close and Restart your project, it will be fixed. if not, you should try other things
     
  28. ravenstara13

    ravenstara13

    Joined:
    Jul 10, 2021
    Posts:
    1
    Hi all! I had a similar issue and I couldn't find the exact help ANYWHERE - I have an Audio Manager and Controller, working with an Array and a Switch basically; only my first musical piece wasn't being played. Turns out I needed to check the Start and Awake methods of my Audio Script components, to make sure they were beginning and collaborating at the right times lol!

    It helped me, maybe it will help somebody out there!
     
  29. MicasDev

    MicasDev

    Joined:
    Apr 10, 2022
    Posts:
    8
    THANK YOU
     
  30. Zaid_Lab

    Zaid_Lab

    Joined:
    Mar 23, 2022
    Posts:
    2
    Do you find any solution to this problem
     
  31. rajanibadri97

    rajanibadri97

    Joined:
    Apr 27, 2022
    Posts:
    1
    Thanks so much.Saves my day
     
  32. lizardman06

    lizardman06

    Joined:
    Feb 14, 2020
    Posts:
    8
    OMG! I legit spent an our and couldnt figure it out it would work on regular speakers but not in headphones thx!!!!
     
  33. parkndrew

    parkndrew

    Joined:
    Jan 5, 2023
    Posts:
    1
    Saved my life, sir!
     
  34. Rorion

    Rorion

    Joined:
    Jun 28, 2019
    Posts:
    5
    I don't know why either, but my Windows Audio Mixer was disabled for Unity! This solved my problem
     
  35. ianway61

    ianway61

    Joined:
    Aug 14, 2021
    Posts:
    1
    In case someone makes a silly mistake like me, I was working in with my Oculus and it turns out the audio was linked to my oculus and not my headphones like windows said so if you are working with an oculus quest try turning up the volume to see if your headset was just muted.
     
  36. cre8ivepark

    cre8ivepark

    Joined:
    Oct 21, 2016
    Posts:
    4
    Thank you! This solution FIXED my issue on Unity 2021.3.19f1! Had no idea why all audio is blocked in Unity editor's play mode.
     
  37. Micka_RedRare

    Micka_RedRare

    Joined:
    Mar 18, 2021
    Posts:
    14
    I had the same problem and I just found the solution. There are two "Mute Audio" buttons. One is on the Scene, the other on the Game window. When you play your game on the Simulator, the button is hidden. Just switch to the Game view, disable Mute Audio, then back to the Simulator. Tada! Sounds and music are back!
    Two Mute buttons...o_O
     
  38. Hydra_zh

    Hydra_zh

    Joined:
    Feb 26, 2023
    Posts:
    1
    u are a life saver man
     
  39. VeganbonD

    VeganbonD

    Joined:
    May 7, 2020
    Posts:
    3
    OMG THANKS! LOL
     
  40. Fumetsujo

    Fumetsujo

    Joined:
    Oct 3, 2015
    Posts:
    1
    Thank you! This fixed my issue. Silly.
     
  41. win9809

    win9809

    Joined:
    Feb 3, 2022
    Posts:
    1
    Your Solution solved my problem. Thanks a lot!
    My problem was audioClip didn't play on Inspector view. Now I can play it pleasantly.
     
  42. yeesgamer

    yeesgamer

    Joined:
    Nov 5, 2022
    Posts:
    2
    Hello i recently import fmod to unity and thought it easy to use fmod
    but i change my mind and delete it
    and after i delete it no audio in my unity editor its so simple just go to project settings -> audio -> there a option called disable unity audio just dont check it make it disable (i mean switch it)
     
  43. pakjiddat

    pakjiddat

    Joined:
    Jan 19, 2023
    Posts:
    1
    I had the same issue. Unchecking the "Mute Audio" button fixed the issue for me. Thanks.
     
  44. netarade

    netarade

    Joined:
    Oct 10, 2023
    Posts:
    1
    My issue was that while debugging with Oculus, the sound initially worked, but at some point, it suddenly stopped altogether. I resolved it by adjusting the audio input and output settings in Oculus to use Windows default instead of Oculus. Take note of this. (Also, check the speaker output device on your PC desktop. When I set it to Windows, the sound is working fine through Windows.)

    It's frustrating when the project works after a fresh start but then stops again, and seeing the sound working when I unplug the Oculus connection cable suggests there might be some issue with the Oculus.
     
    Last edited: Nov 27, 2023
  45. serjeq

    serjeq

    Joined:
    May 23, 2017
    Posts:
    24
    Thx bro.. In my layout the "mute game button" was hidden, due to not enough screen space (scene and game view are side to side vertically) so I wouldn't figured it out without your comment.
     
  46. Chakanshu

    Chakanshu

    Joined:
    Jul 29, 2020
    Posts:
    1
    It was this simple. I hate myself. Thank you so much btw
     
  47. unity_858DA074E82A004A4F8B

    unity_858DA074E82A004A4F8B

    Joined:
    Feb 15, 2024
    Posts:
    1
    This saved me. Thanks a lot
     
  48. Deltasfer2

    Deltasfer2

    Joined:
    Oct 19, 2022
    Posts:
    4
    I know this is a very old message but for those who will face the same problem I figure it out.
    if you followed this tutorial :


    It's an old tutorial and things in unity may have changed :), now the default pitch for audio is 1. So if in your AudioManager your AudioSource components have a pitch to 0, they will be muted.

    Change the audio pitch to 1 in your list of Sounds in the AudioManager, and you're done :D