Search Unity

  1. Welcome to the Unity Forums! Please take the time to read our Code of Conduct to familiarize yourself with the forum rules and how to post constructively.

Audio Not playing in Unity at all. [SOLVED]

Discussion in 'Audio & Video' started by tmanallen, Jul 3, 2016.

  1. tmanallen

    tmanallen

    Joined:
    Nov 8, 2009
    Posts:
    395
    Hello all,
    Question, I am trying to get audio to play and nothing seems to work anymore. I can't get it to play in the editor or even after I do a build for windows, haven't tried a mobile build because the game is intended for standalone, any help is appreciated, I have audio downloaded from the unity store and it plays in windows player with no problem and I have sound coming out of my speakers, but not for unity, I have windows 10 of course, any suggestions?
     
  2. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    Which version of Unity are you using?
     
  3. janm_unity3d

    janm_unity3d

    Unity Technologies

    Joined:
    Jun 12, 2012
    Posts:
    36
    Minecraftian14 and tmanallen like this.
  4. tmanallen

    tmanallen

    Joined:
    Nov 8, 2009
    Posts:
    395
    CloudyVR likes this.
  5. MrEsquire

    MrEsquire

    Joined:
    Nov 5, 2013
    Posts:
    2,712
    Yeh I asked you which version of Unity you use? so sorry but you not understanding that its to do with Unity versions here.
     
  6. tmanallen

    tmanallen

    Joined:
    Nov 8, 2009
    Posts:
    395
    Sorry, I didn't see your reply, it didn't show up when I first replied, 5.3.5f1.
     
  7. tmanallen

    tmanallen

    Joined:
    Nov 8, 2009
    Posts:
    395
    So your saying I need to get an updated version of unity, it's not that I didn't understand, I just never saw you questions, my apologies.
     
    MrEsquire likes this.
  8. rorywalsh

    rorywalsh

    Joined:
    Apr 10, 2015
    Posts:
    114
    I'm using 5.3.5f and I'm not having any issues. What OS are you using? Can you try creating a new project and seeing if audio works in it. This will at least rule out a problem with your project.
     
  9. tmanallen

    tmanallen

    Joined:
    Nov 8, 2009
    Posts:
    395
    I have tried that also, still not know what I am doing wrong, I have downloaded the audio from the asset store also to make sure the format was correct. I have windows 10 OS also.
     
  10. rorywalsh

    rorywalsh

    Joined:
    Apr 10, 2015
    Posts:
    114
    Same OS as I have. Are sounds playing Ok in other applications?
     
  11. janm_unity3d

    janm_unity3d

    Unity Technologies

    Joined:
    Jun 12, 2012
    Posts:
    36
    Do you see any mention of FMOD initialization errors in the Unity Editor.log file? (c:\Users\YourUserName\AppData\Local\Unity\Editor\Editor.log) If so, does it help changing the sample rate of your sound card?
     
  12. tmanallen

    tmanallen

    Joined:
    Nov 8, 2009
    Posts:
    395

    Yes they are, I can run the same sounds on anything else.
     
  13. tmanallen

    tmanallen

    Joined:
    Nov 8, 2009
    Posts:
    395
    This is what I have in my editor.log Audio: FMOD Profiler initialized on port 54900
     
  14. tmanallen

    tmanallen

    Joined:
    Nov 8, 2009
    Posts:
    395
    Don't know what happened, but for some reason, Unity started out as muted on my desktop. I went to check my mixer and for some reason under unity it said mute, thanks everyone for the ideas and suggestions.
     
    edemszki and BrainSlugs83 like this.
  15. eskivor

    eskivor

    Joined:
    Aug 5, 2015
    Posts:
    12
    Edit -> Projects Settings -> Audio -> Check that "Global Volume" is not equal to 0.
     
    Nicolas_Granese likes this.
  16. CNR-EpiTel

    CNR-EpiTel

    Joined:
    Aug 23, 2018
    Posts:
    12
    Is there any reason why audio is not streaming at all?
    I am trying to solve it.

    It began when I was working with demo scenes, like Weather Manager.
    My games are all daydream.
    I have re-downloaded fresh versions of Unity 2017 LTS and 2018 8,7 and 4.
    All of them have no unity audio.

    I am only using standard assets and standard scenes .
    Still nothing.

    My drivers are fine.
    This does not make sense.
    Where is the problem source from? How can I fix it?
     

    Attached Files:

  17. ninjanosui

    ninjanosui

    Joined:
    Jul 12, 2013
    Posts:
    54
    I have the same issue. The audio toggle is getting greyed out as soon as I press play. When I make a build it works as it should.
     
    Avisan, shasaur_unity and joi711 like this.
  18. rolisun

    rolisun

    Joined:
    Nov 25, 2017
    Posts:
    1
    I test audio without scripts, just the basic method dragging and dropping audio file, and the audio file (.mp3 or .wav) only in the scene, last unity version, but in play mode, audio cannot be listened, laptop audio is fine, but not at unity. This despite doing the same thing or procedure in several videos or references. I make the same questions: Where is the problem source from? How can I fix it?
     
    steveo98501 and zoystudios like this.
  19. ST_Team

    ST_Team

    Joined:
    Sep 1, 2017
    Posts:
    1
    I have the same problem. BUT when I export everything as an *.exe file everything works fine. So for me it seems to be an bug?!?
     
  20. CNR-EpiTel

    CNR-EpiTel

    Joined:
    Aug 23, 2018
    Posts:
    12
    Yes, the
    Yes, the export will workfine. It is independent of the historic platform.
     
  21. ArchbaldCortez

    ArchbaldCortez

    Joined:
    Sep 1, 2017
    Posts:
    2
    Check you don't have "Mute Audio" enabled:
    upload_2018-10-10_16-40-40.png
     
  22. sgower

    sgower

    Joined:
    Mar 9, 2015
    Posts:
    316
    I was scratching my head today wondering why all audio had stopped for me. Turned out,I had clicked on that "Mute Audio" button by mistake. :) Thanks ArchbaldCortez.
     
    narendra57, Leohd, steveh2112 and 2 others like this.
  23. P_Jong

    P_Jong

    Joined:
    Jun 14, 2017
    Posts:
    58
    @ArchbaldCortez thank you! I must have accidently checked "Mute Audio" on the Game window. I don't know when or how I did that today. I must have spent 3 hrs trying to find out what happened. I even pulled my project from backup and it was still muted. But now I realize it was the editor and I must had accidently clicked it while testing my game today. I think a "Mute" editor setting should not be saved when exiting the editor. Really do our TVs stay muted when we restart them? Well now I know and this will be the first thing I check before going to backup and re-installing Oculus Rift and pulling and putting back in HDMI cables. Really 3 hrs was lost today and all I had to do was click "Mute Audio". I feel like I was looking for my glasses and they were on my head the whole time. lol
     
  24. mafole4x

    mafole4x

    Joined:
    Dec 15, 2015
    Posts:
    6
    Alternative way,
    1. If tried the options discussed and have not yet got the sound system back,then

    2.Another way
    Edit -> Project Settings -> Audio -> System Sample Rate (change it from "0" to "1").
    That's all :)
     
    parkndrew, CodeXiD, rpie3 and 23 others like this.
  25. thefallengamesstudio

    thefallengamesstudio

    Joined:
    Mar 7, 2016
    Posts:
    672
    This was my issue too.

    Why is Mute Audio ticked by default in a new project? Can someone form unity answer?
    Thanks
     
    mhussar and winterkewl like this.
  26. rajvray

    rajvray

    Joined:
    Apr 14, 2019
    Posts:
    27
    MrRIU5, P_Jong and winterkewl like this.
  27. fizzd

    fizzd

    Joined:
    Jul 30, 2013
    Posts:
    21
    This worked for me, thanks! Setting it back to 0 again afterwards kept it working. Looks like changing the value forced FMOD to refresh something.

    EDIT: It happened again, and this fix didn't work anymore. But I finally figured out that it was because my platform was set to Android. Don't know why, but changing back to windows fixed it.
     
    Last edited: Jul 28, 2019
  28. isaacgomes0896

    isaacgomes0896

    Joined:
    Sep 5, 2019
    Posts:
    1
    Try add the audio listener component. It worked for me
     
    paul_unity171 and wanderbox like this.
  29. hedidev

    hedidev

    Joined:
    Aug 11, 2019
    Posts:
    2
    see if "mute audio" in the game window is checked or not , or maybe you didn't set your audio to play in awake in the inspector ,
     
  30. zoystudios

    zoystudios

    Joined:
    Nov 2, 2017
    Posts:
    1
    Thanks I Got It
     
  31. ibnerahim1

    ibnerahim1

    Joined:
    Jan 26, 2019
    Posts:
    1
    Thanks a lot ArchbaldCortez, I'm really laughing at myself as i was struggling a lot from this for a complete day as i disabled it by mistake and was searching everywhere for the solution but finally got it
     
  32. olonge

    olonge

    Joined:
    Sep 22, 2014
    Posts:
    16
  33. ArtemVy

    ArtemVy

    Joined:
    Jan 25, 2015
    Posts:
    6
    A half hour was spend on that :confused:
    Thank you! Mute Audio is a devil button, that hides sometimes behind other panels.
     
  34. Zandra808

    Zandra808

    Joined:
    May 9, 2017
    Posts:
    2
    Hahaa... I had to delete all my unity versions... And I still couldn't see that button was turned on!
     
    wanrclhnyd likes this.
  35. m0m0ney

    m0m0ney

    Joined:
    Dec 13, 2019
    Posts:
    1
    LoL, I experienced the same problem, I had to scroll down to see the Volume on button.

    Volume_On.png
     
    Last edited: Dec 13, 2019
  36. steveh2112

    steveh2112

    Joined:
    Aug 30, 2015
    Posts:
    246
    i've been debugging a dead audio problem for almost a day and i complete missed that i set mute audio on a different project and when i created my current project, i guess unity somehow remembered it.
     
  37. wanderbox

    wanderbox

    Joined:
    Feb 12, 2020
    Posts:
    3
    Thank you! I had added an XR Rig from Unity's XR Interaction Toolkit. It turns out the main camera didn't come with an audio listener.
     
  38. Kagedmonkey40

    Kagedmonkey40

    Joined:
    Feb 2, 2016
    Posts:
    5
    OMG! I just had the same problem. Somehow in middle of playing my game (testing) my wrist must have bumped mousepad and clicked that mute. I spent an hour checking my code, another few testing my audio through other applications. Last resort I rebooted machine and restarted Unity...still no audio. Thanks ArchbaldCortez. for posting the "mute button" I was getting serious ticked off!
     
  39. dajohnso

    dajohnso

    Joined:
    Apr 17, 2020
    Posts:
    1
    You are brilliant!!!! I did the same thing!
     
  40. Navoan

    Navoan

    Joined:
    Mar 15, 2014
    Posts:
    1
    I swear to god, after well over an hour trying to fix this issue... it was a simple mute toggle I had no idea even existed until now. Thank you...
     
  41. futurewavecs

    futurewavecs

    Joined:
    Jul 26, 2012
    Posts:
    72
    I am fighting with this right now. Mute audio is not checked. I also tried toggling sampling mode in project settings. The bizarre thing is that I have an audio source and audio listener set up the same in one scene and it works. Then in the scene I am currently working on it doesn't work. I am upgrading to 2019.3.13f1 now to see if maybe it is a bug. I was using 2019.3.11f1.
     
    joi711 likes this.
  42. joi711

    joi711

    Joined:
    Apr 11, 2020
    Posts:
    1
    I have this issue as well. Mute audio is not checked. I tried toggling sampling mode in project settings but this did not work. Disable unity audio is not checked. There is an audio listener on my camera. But, the toggle audio button still keeps greying out when I click Play. I am using 2019.3.14f1.
     
    Last edited: May 24, 2020
  43. kstefanowska

    kstefanowska

    Joined:
    Oct 25, 2019
    Posts:
    3
    Same, my AudioManager script from here:
    worked well in Unity 2018.4.10f, but in Unity 2019.3.0f5 it doesn't. Creating manualy some Audio Sources on objects does work properly, but the AudioManager script (even though it creates it's own Audio Source and it seems to work just fine) doesn't give a single sound out, neither in the engine, nor in the build.
     
  44. froilan_dE_dios

    froilan_dE_dios

    Joined:
    Jul 28, 2015
    Posts:
    17
    The sound needs to be played in coroutine. Something like this

    void Update()
    {
    if (playerCharacter.isSwimming)
    {
    if(canPlaySound)
    {
    canPlaySound = false;
    StartCoroutine(Play_Sound());
    }

    }
    else
    {
    audio.Stop();
    }
    }

    IEnumerator Play_Sound()
    {
    audio.Play();
    yield return new WaitForSeconds(audio.clip.length);
    canPlaySound = true;
    }
     
  45. dontknowname

    dontknowname

    Joined:
    Mar 3, 2020
    Posts:
    2
    Mute audio is not checked. And I can hear other sounds, like hooves for deer. But I can't hear the background music. In addition, after the game starts about 4 mins later, the BGM will suddenly turn on.
    I don't know what's going on. The BGM works well yesterday.
    Where is the problem source from? How can I fix it?
    截屏2020-06-03下午9.48.13.jpg 截屏2020-06-03下午9.51.38.jpg
     
    Last edited: Jun 4, 2020
  46. FLIPAPANCAKE

    FLIPAPANCAKE

    Joined:
    Feb 27, 2020
    Posts:
    2
    the reason why your audio is not working is because its muted i had the same issue i checked my Audio source and even if the check box is not set to be muted there is a mute Audio next to your game scene view that will mute it you can simply click the mute audio button to unmute it hope this helps
     
  47. CaptainAk2310

    CaptainAk2310

    Joined:
    May 1, 2020
    Posts:
    1
    yes, even i tried it right now by creating array and putting it as source to listener and had same problem , did all the solutions mentioned as above & still didnt worked , so tried on single object by putting as source, and it worked. So i guess , script needs a modification of some kind (m new to programming so dnt know, what kind of, till now ) but one thing is sure, unity's audio is working as it worked for diff audio source and same listener.
     
  48. Skitcher86

    Skitcher86

    Joined:
    Mar 12, 2020
    Posts:
    1
    I just reset the audio component in the project settings menu and it played all audio. So Edit>ProjectSettings>audio, click the cog wheel on the right side across from audio, and then click reset. it may change any audio presets you have made (not really sure) but, it fixed my problem. Unity - 2019.4.0f1
     
    DIEGENDO likes this.
  49. dandatron

    dandatron

    Joined:
    Oct 1, 2019
    Posts:
    2
    I have a problem of my own, I have recently had sound problems for no reason at all, this is a complaint I have always had with unity(the fact that the software creates its own problems out of the blue) my sound always worked fine, for the 2 years so far that I have been developping my game. But now for some reason not only does it glitch and sound buggy, if it even plays at all. Two different sounds wont play at the same time. I have a boss fight with music and roars froms the boss. Everytime he roars the music cuts off and I hate how that happens. It ruins the effect of the battle. Inside unity there appears to be no visible problem, everything gets ticked on at just the right time but for some reason it s does not work. I have spent years on this game, I wont have it ruined by unity problems please help
     
  50. NeverTrustShadows

    NeverTrustShadows

    Joined:
    Mar 15, 2020
    Posts:
    9
    Thanks mate, I really appreciate this obvious solution.
     
    jasonrbrock and Rachan like this.